Bug 165566

Summary: Allow commas in Accept, Accept-Language, and Content-Language request headers for simple CORS
Product: WebKit Reporter: John Wilander <wilander>
Component: WebCore Misc.Assignee: John Wilander <wilander>
Status: RESOLVED FIXED    
Severity: Normal CC: commit-queue, mike, webkit-bug-importer, wilander, youennf
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
See Also: https://bugs.webkit.org/show_bug.cgi?id=165178
https://bugs.webkit.org/show_bug.cgi?id=166363
Attachments:
Description Flags
Patch none

Description John Wilander 2016-12-07 16:41:19 PST
https://bugs.webkit.org/show_bug.cgi?id=165178 caused a regression since it doesn't allow commas in Accept, Accept-Language, and Content-Language request headers for simple CORS.
Comment 1 John Wilander 2016-12-07 16:42:18 PST
rdar://problem/29560983
Comment 2 John Wilander 2016-12-07 16:42:51 PST
Also rdar://problem/29562808.
Comment 3 John Wilander 2016-12-07 16:48:49 PST
Created attachment 296439 [details]
Patch
Comment 4 WebKit Commit Bot 2016-12-07 18:08:56 PST
Comment on attachment 296439 [details]
Patch

Clearing flags on attachment: 296439

Committed r209510: <http://trac.webkit.org/changeset/209510>
Comment 5 WebKit Commit Bot 2016-12-07 18:09:00 PST
All reviewed patches have been landed.  Closing bug.