Bug 16513

Summary: Whitespace affects rendering of inline unordered list items with padding
Product: WebKit Reporter: David Kilzer (:ddkilzer) <ddkilzer>
Component: New BugsAssignee: Nobody <webkit-unassigned>
Status: RESOLVED CONFIGURATION CHANGED    
Severity: Normal CC: mitz
Priority: P2 Keywords: HasReduction, InRadar
Version: 528+ (Nightly build)   
Hardware: Mac   
OS: OS X 10.4   
URL: http://bugs.webkit.org/attachment.cgi?id=17268&action=view
Attachments:
Description Flags
Test case none

Description David Kilzer (:ddkilzer) 2007-12-18 22:40:28 PST
* SUMMARY
Whitespace affects the rendering of unordered-list-as-tabs.  See URL for details.

* STEPS TO REPRODUCE
1. Launch Safari/WebKit.
2. Open URL:  http://bugs.webkit.org/attachment.cgi?id=17268&action=view

* RESULTS
The "ON THE WEB" tab on the top is rendered differently than the "ON THE WEB" tab on the bottom.

* REGRESSION
Unknown.  Only tested with a local debug build of WebKit r28828 with Safari 3.0.4 (523.12) on Mac OS X 10.4.11 (8S165).

* NOTES
Both tabs render as expected with Firefox 2.0.0.11 and Opera 9.24.
Comment 1 David Kilzer (:ddkilzer) 2007-12-18 22:49:27 PST
(In reply to comment #0)
> * STEPS TO REPRODUCE
> 1. Launch Safari/WebKit.
> 2. Open URL:  http://bugs.webkit.org/attachment.cgi?id=17268&action=view

Test case originally attached to Bug 14134.

Comment 2 David Kilzer (:ddkilzer) 2007-12-19 06:38:26 PST
Created attachment 17990 [details]
Test case

In Firefox 2.0.0.11, both green boxes are the same width and height.

In MSIE 7, both green boxes are the same height, but the width of the bottom box is a few pixels smaller than the top box.

In a local debug build of WebKit r28828 with Safari 3.0.4 (523.12) on Mac OS X 10.4.11 (8S165), the bottom box is smaller in width and height than the top box.

Interesting things that affect the width and height:
- Removing/adding <span> tags.  (They were changed from <em> tags, but <strong> tags work as well.)
- Adding/removing whitespace before </li> elements.
- Removing/adding empty <li></li> elements.
Comment 3 Mark Rowe (bdash) 2008-06-16 14:29:49 PDT
<rdar://problem/6012946>
Comment 4 mitz 2008-06-16 14:31:04 PDT
Perhaps a duplicate of bug 8392.
Comment 5 mitz 2021-11-29 15:38:53 PST
The test case passes in TOT.