Bug 164923

Summary: Crashes in WebCore::ElementRuleCollector::matchHostPseudoClassRules
Product: WebKit Reporter: Dieter Komendera <dieter>
Component: WebCore Misc.Assignee: Nobody <webkit-unassigned>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: aroben, koivisto
Priority: P2 Keywords: InRadar
Version: Safari Technology Preview   
Hardware: Macintosh   
OS: macOS 10.12   
Attachments:
Description Flags
crash log none

Description Dieter Komendera 2016-11-18 06:22:49 PST
Created attachment 295144 [details]
crash log

I get a lot of those crashes when interacting with Issues and Pull Requests on Github.com

Actions on GitHub issues I often, but not always, get this crash:

* assign an issue or pull request to one or multiple collaborators
* assign tags to an issue or pull request
* add a comment to an issue or pull request

I think these crashes started to happen with Safari Technology Preview Release 16.

The still happens with Release 18 (Safari 10.1, WebKit 12603.1.12) on macOS 10.12.1 (16B2555)

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0   com.apple.WebCore             	0x000000010a6956b0 WebCore::ElementRuleCollector::matchHostPseudoClassRules(WebCore::MatchRequest&, WebCore::StyleResolver::RuleRange&) + 240
1   com.apple.WebCore             	0x000000010a17f062 WebCore::ElementRuleCollector::matchAuthorRules(bool) + 194
2   com.apple.WebCore             	0x000000010a17ede2 WebCore::ElementRuleCollector::matchAllRules(bool, bool) + 626
3   com.apple.WebCore             	0x000000010b1a5004 WebCore::StyleResolver::styleForElement(WebCore::Element const&, WebCore::RenderStyle const*, WebCore::RuleMatchingBehavior, WebCore::RenderRegion const*, WebCore::SelectorFilter const*) + 932
4   com.apple.WebCore             	0x000000010a68caf0 WebCore::Element::resolveStyle(WebCore::RenderStyle const*) + 96
5   com.apple.WebCore             	0x000000010a60d297 WebCore::Document::styleForElementIgnoringPendingStylesheets(WebCore::Element&, WebCore::RenderStyle const*) + 71
6   com.apple.WebCore             	0x000000010a690f58 WebCore::Element::resolveComputedStyle() + 696
7   com.apple.WebCore             	0x000000010a1ca9a2 WebCore::Element::computedStyle(WebCore::PseudoId) + 194
Comment 1 Alexey Proskuryakov 2016-11-18 15:52:49 PST
rdar://problem/28990966
Comment 2 Antti Koivisto 2016-11-23 06:33:54 PST

*** This bug has been marked as a duplicate of bug 165030 ***