Bug 164791

Summary: Rename CONCURRENT_JIT/ConcurrentJIT to CONCURRENT_JS/ConcurrentJS
Product: WebKit Reporter: Filip Pizlo <fpizlo>
Component: JavaScriptCoreAssignee: Filip Pizlo <fpizlo>
Status: RESOLVED FIXED    
Severity: Normal CC: benjamin, cdumez, cmarcelo, commit-queue, dbates, keith_miller, mark.lam, msaboff, saam
Priority: P2    
Version: WebKit Nightly Build   
Hardware: All   
OS: All   
Bug Depends on:    
Bug Blocks: 149432    
Attachments:
Description Flags
the patch ggaren: review+

Description Filip Pizlo 2016-11-15 14:04:09 PST
Both the concurrent GC and the concurrent JIT rely on concurrency support in fundamental JSC runtime components like JSValue.  So, the thing that guards it should be a "feature" called CONCURRENT_JS not CONCURRENT_JIT.
Comment 1 Filip Pizlo 2016-11-15 14:10:14 PST
Created attachment 294879 [details]
the patch
Comment 2 WebKit Commit Bot 2016-11-15 14:13:03 PST
Attachment 294879 [details] did not pass style-queue:


ERROR: Source/JavaScriptCore/bytecode/LazyOperandValueProfile.h:158:  The parameter name "key" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/JavaScriptCore/bytecode/LazyOperandValueProfile.h:172:  The parameter name "holder" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/JavaScriptCore/bytecode/LazyOperandValueProfile.h:178:  The parameter name "key" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/JavaScriptCore/runtime/JSObject.h:761:  The parameter name "structure" adds no information, so it should be removed.  [readability/parameter_name] [5]
Total errors found: 4 in 74 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 Geoffrey Garen 2016-11-15 14:16:50 PST
Comment on attachment 294879 [details]
the patch

rs=me
Comment 4 Filip Pizlo 2016-11-15 15:22:24 PST
Landed in https://trac.webkit.org/changeset/208761
Comment 5 Filip Pizlo 2016-11-15 17:36:12 PST
Fixed a regression in https://trac.webkit.org/changeset/208777