Bug 164599

Summary: REGRESSION: API test _WKDownload.CancelDownload is a flaky failure
Product: WebKit Reporter: Ryan Haddad <ryanhaddad>
Component: New BugsAssignee: Nobody <webkit-unassigned>
Status: RESOLVED CONFIGURATION CHANGED    
Severity: Normal CC: achristensen, ap, cgarcia
Priority: P2    
Version: Other   
Hardware: Unspecified   
OS: Unspecified   
See Also: https://bugs.webkit.org/show_bug.cgi?id=164631
https://bugs.webkit.org/show_bug.cgi?id=176422

Description Ryan Haddad 2016-11-10 09:54:36 PST
API test _WKDownload.CancelDownload is a flaky failure

FAIL _WKDownload.CancelDownload

/Volumes/Data/slave/elcapitan-debug/build/Tools/TestWebKitAPI/Tests/WebKit2Cocoa/Download.mm:204
Value of: false
  Actual: false
Expected: true

https://build.webkit.org/builders/Apple%20El%20Capitan%20Debug%20WK2%20%28Tests%29/builds/9316
Comment 1 Ryan Haddad 2016-11-10 23:46:09 PST
This is probably related to http://trac.webkit.org/changeset/208521
Comment 2 Alexey Proskuryakov 2016-11-11 23:24:10 PST
Adding REGRESSION based on the above comment.
Comment 3 Ryan Haddad 2016-11-15 15:23:27 PST
Any update on this?
Comment 4 Carlos Garcia Campos 2016-11-15 22:22:28 PST
My comment 6 on bug #164631 applies here as well, I think both failures are caused by the same problem. I would love to help, but I don't have a mac to debug this, so I can only guess. I can try to ensure that in case of not using network session the code does exactly the same as before r208521.
Comment 5 Alex Christensen 2016-11-17 23:17:46 PST
I can't reproduce this by adding a usleep call like I did in bug 164631.  I'm not sure if this is fixed, then.
Comment 6 Alexey Proskuryakov 2016-11-29 12:40:44 PST
Ryan, do you know if this is still happening?
Comment 7 Ryan Haddad 2016-11-29 12:42:08 PST
(In reply to comment #6)
> Ryan, do you know if this is still happening?

I'm not seeing it anymore. Moving to config changed.