Bug 163711

Summary: [WebIDL] Support converting Dictionary type objects from native types to JSValue
Product: WebKit Reporter: Jiewen Tan <jiewen_tan>
Component: BindingsAssignee: Nobody <webkit-unassigned>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: cdumez, jason.mei, jiewen_tan
Priority: P2    
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   

Description Jiewen Tan 2016-10-19 17:12:17 PDT
We now can convert Dictionary type objects from JSValue to native types, but we lack the other way.
Comment 1 Chris Dumez 2016-11-17 12:14:06 PST
Apparently useful for CryptoKeyPair.
Comment 2 Jiewen Tan 2016-11-17 12:17:48 PST
(In reply to comment #1)
> Apparently useful for CryptoKeyPair.

And JsonWebKey.
Comment 3 Brady Eidson 2016-12-02 13:57:35 PST
*** Bug 164868 has been marked as a duplicate of this bug. ***
Comment 4 Jiewen Tan 2016-12-07 11:40:59 PST

*** This bug has been marked as a duplicate of bug 165367 ***