Bug 161102

Summary: CSS.supports.length is 2 instead of 1
Product: WebKit Reporter: Joseph Pecoraro <joepeck>
Component: BindingsAssignee: Nobody <webkit-unassigned>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: cdumez, joepeck
Priority: P2    
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   

Description Joseph Pecoraro 2016-08-23 13:37:30 PDT
CSS.supports.length is 2 instead of 1.

There are two methods in the IDL:
Source/WebCore/css/DOMCSSNamespace.idl

interface DOMCSSNamespace {
    static boolean supports(DOMString property, DOMString value);
    static boolean supports(DOMString conditionText);
};

The final length should probably be the shortest length of all same-name functions.
Comment 1 Chris Dumez 2016-08-23 14:43:26 PDT
> The final length should probably be the shortest length of all same-name functions.

I already fixed that in https://bugs.webkit.org/show_bug.cgi?id=160303 AFAIK?
Comment 2 Chris Dumez 2016-08-23 14:45:01 PDT
CSS.supports.length is 1 in WebKit ToT...
Comment 3 Chris Dumez 2016-08-23 14:45:10 PDT

*** This bug has been marked as a duplicate of bug 160303 ***
Comment 4 Joseph Pecoraro 2016-08-23 15:04:29 PDT
(In reply to comment #2)
> CSS.supports.length is 1 in WebKit ToT...

Yep. I was using an older build. Thanks!