Bug 158959

Summary: REGRESSION(r202157): ASSERTION FAILED: !codeBlock->m_didFailJITCompilation on executableAllocationFuzz.yaml/executableAllocationFuzz/v8-raytrace.js.executable-allocation-fuzz-default
Product: WebKit Reporter: Alexey Proskuryakov <ap>
Component: JavaScriptCoreAssignee: Nobody <webkit-unassigned>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: fpizlo, ryanhaddad, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: Other   
Hardware: Unspecified   
OS: Unspecified   

Description Alexey Proskuryakov 2016-06-20 16:57:06 PDT
executableAllocationFuzz.yaml/executableAllocationFuzz/v8-raytrace.js.executable-allocation-fuzz-default very frequently asserts in debug builds.

ASSERTION FAILED: !codeBlock->m_didFailJITCompilation
/Volumes/Data/slave/elcapitan-debug/build/Source/JavaScriptCore/jit/JITWorklist.cpp(205) : void JSC::JITWorklist::compileNow(JSC::CodeBlock *)
1   0x10e375480 WTFCrash
2   0x10ded9638 JSC::JITWorklist::compileNow(JSC::CodeBlock*)
3   0x10d9af4db JSC::DFG::prepareCodeOriginForOSRExit(JSC::ExecState*, JSC::CodeOrigin)
4   0x10d99de79 compileOSRExit
5   0x38a6ee40531b
6   0x38a6ee4160ba
7   0x38a6ee423cb3
8   0x10df99a3f llint_entry
9   0x10df99ab9 llint_entry
10  0x10df99ab9 llint_entry
11  0x10df92b2e vmEntryToJavaScript
12  0x10dd8493a JSC::JITCode::execute(JSC::VM*, JSC::ProtoCallFrame*)
13  0x10dd0edd8 JSC::Interpreter::execute(JSC::ProgramExecutable*, JSC::ExecState*, JSC::JSObject*)
14  0x10d68d110 JSC::evaluate(JSC::ExecState*, JSC::SourceCode const&, JSC::JSValue, WTF::NakedPtr<JSC::Exception>&)
15  0x10d1b8c4c runWithScripts(GlobalObject*, WTF::Vector<Script, 0ul, WTF::CrashOnOverflow, 16ul> const&, WTF::String const&, bool, bool)
16  0x10d1b80d7 runJSC(JSC::VM*, CommandLine)
17  0x10d1b719a jscmain(int, char**)
18  0x10d1b704b main
19  0x7fff970745ad start
Failure for command ../../../.vm/JavaScriptCore.framework/Resources/jsc v8-raytrace.js with seed 1466224696, repeat 20: Cannot execute command on iteration 6, status 11 for target 1 at ../../../.helpers/js-executable-allocation-fuzz line 65.
ERROR: Unexpected exit code: 255
Comment 1 Radar WebKit Bug Importer 2016-06-20 16:57:32 PDT
<rdar://problem/26905445>
Comment 2 Filip Pizlo 2016-06-23 10:08:14 PDT

*** This bug has been marked as a duplicate of bug 158806 ***