Bug 158644

Summary: LayoutTest storage/indexeddb/database-close-private.html is flaky
Product: WebKit Reporter: Ryan Haddad <ryanhaddad>
Component: New BugsAssignee: Nobody <webkit-unassigned>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: beidson
Priority: P2    
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   

Description Ryan Haddad 2016-06-10 17:01:23 PDT
LayoutTest storage/indexeddb/database-close-private.html is flaky

<https://build.webkit.org/builders/Apple%20El%20Capitan%20Debug%20WK1%20(Tests)/builds/5867>
<https://webkit-test-results.webkit.org/dashboards/flakiness_dashboard.html#showAllRuns=true&tests=storage%2Findexeddb%2Fdatabase-close-private.html>

--- /Volumes/Data/slave/elcapitan-debug-tests-wk1/build/layout-test-results/storage/indexeddb/database-close-private-expected.txt
+++ /Volumes/Data/slave/elcapitan-debug-tests-wk1/build/layout-test-results/storage/indexeddb/database-close-private-actual.txt
@@ -43,10 +43,8 @@
 transaction #2 request successful
 PASS event.target.result is "value2"
 
-All transactions completed - database deletes should now be unblocked.
-
 delete database unblocked
-PASS awaiting_transaction_count is 0
+FAIL awaiting_transaction_count should be 0. Was 1.
 PASS successfullyParsed is true
 
 TEST COMPLETE
Comment 1 Ryan Haddad 2016-06-10 17:02:42 PDT
Seems to intermittently fail on bot Mac WK1 and WK2, but more frequently on WK1.
Comment 2 Brady Eidson 2016-06-11 17:42:50 PDT
Right - We already know this:
https://bugs.webkit.org/show_bug.cgi?id=158500

*** This bug has been marked as a duplicate of bug 158500 ***