Bug 156536

Summary: [meta] Move MathML attribute parsing from the renderer classes to the element classes
Product: WebKit Reporter: Frédéric Wang (:fredw) <fred.wang>
Component: MathMLAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: svillar
Priority: P2    
Version: WebKit Nightly Build   
Hardware: All   
OS: All   
Bug Depends on: 156537, 156792, 156795, 159620, 159622, 159623, 159624, 159625    
Bug Blocks:    

Description Frédéric Wang (:fredw) 2016-04-13 07:41:44 PDT
Currently, most of the MathML attributes are parsed in the renderer classes, while we should follow the standard way and parse attributes in the element classes. Hopefully, this will improve the management of dynamic update. There is already bug 118900 to do that for length attributes but this is a meta bug to track the most general case.
Comment 1 Frédéric Wang (:fredw) 2016-07-11 07:33:48 PDT
*** Bug 118900 has been marked as a duplicate of this bug. ***
Comment 2 Frédéric Wang (:fredw) 2016-08-03 00:04:02 PDT
All MathML attributes are now parsed in element classes.