Bug 15644

Summary: HTML and SVG need to share more text painting code
Product: WebKit Reporter: Eric Seidel (no email) <eric>
Component: SVGAssignee: Nobody <webkit-unassigned>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: zimmermann
Priority: P2    
Version: 523.x (Safari 3)   
Hardware: Mac   
OS: OS X 10.4   

Description Eric Seidel (no email) 2007-10-23 15:19:22 PDT
HTML and SVG need to share more text painting code

I was looking through the SVG text painting code today and I realized that a good bit of it is just copy/paste.  One glaring example:

    // Set a text shadow if we have one.
    // FIXME: Support multiple shadow effects.  Need more from the CG API before
    // we can do this.
    bool setShadow = false;
    if (styleToUse->textShadow()) {
        paintInfo.context->setShadow(IntSize(styleToUse->textShadow()->x, styleToUse->textShadow()->y),
                                     styleToUse->textShadow()->blur, styleToUse->textShadow()->color);
        setShadow = true;
    }

What happens when the HTML text side finally fixes that bug?  It will be broken for SVG too, unless we abstract that (and other) logic into a single shared function.
Comment 1 Nikolas Zimmermann 2010-06-17 01:39:15 PDT
40663 will fix this bug.

*** This bug has been marked as a duplicate of bug 40663 ***