Bug 155660

Summary: Sideways-scrollable RTL document has wrong initial and reload offset in WKWebView
Product: WebKit Reporter: Simon Fraser (smfr) <simon.fraser>
Component: New BugsAssignee: Simon Fraser (smfr) <simon.fraser>
Status: RESOLVED FIXED    
Severity: Normal CC: bdakin, commit-queue, simon.fraser, thorton
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch thorton: review+

Description Simon Fraser (smfr) 2016-03-18 13:23:05 PDT
Sideways-scrollable RTL document has wrong initial and reload offset in WKWebView
Comment 1 Simon Fraser (smfr) 2016-03-18 13:47:43 PDT
Created attachment 274452 [details]
Patch
Comment 2 WebKit Commit Bot 2016-03-18 13:49:38 PDT
Attachment 274452 [details] did not pass style-queue:


ERROR: Source/WebKit2/ChangeLog:16:  Line contains tab character.  [whitespace/tab] [5]
ERROR: Source/WebKit2/ChangeLog:17:  Line contains tab character.  [whitespace/tab] [5]
ERROR: Source/WebKit2/ChangeLog:19:  Line contains tab character.  [whitespace/tab] [5]
ERROR: Source/WebKit2/ChangeLog:20:  Line contains tab character.  [whitespace/tab] [5]
ERROR: Source/WebKit2/ChangeLog:21:  Line contains tab character.  [whitespace/tab] [5]
ERROR: Source/WebKit2/ChangeLog:22:  Line contains tab character.  [whitespace/tab] [5]
ERROR: Source/WebKit2/ChangeLog:23:  Line contains tab character.  [whitespace/tab] [5]
ERROR: Source/WebKit2/ChangeLog:24:  Line contains tab character.  [whitespace/tab] [5]
ERROR: Source/WebKit2/ChangeLog:25:  Line contains tab character.  [whitespace/tab] [5]
Total errors found: 9 in 18 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 Tim Horton 2016-03-18 14:17:30 PDT
Comment on attachment 274452 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=274452&action=review

> Source/WebKit2/UIProcess/API/Cocoa/WKWebView.mm:1269
> +    _commitDidRestoreExposedRect = NO;

I would expect "didCommitLayerTree" to be after the commit is complete :D maybe _didCommitLayerTree should be called _commitLayerTree or _willCommitLayerTree or something. Or not.