Bug 155086

Summary: RenderTextControlSingleLine shouldn't mutate placeholder element inline style
Product: WebKit Reporter: Antti Koivisto <koivisto>
Component: DOMAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: commit-queue
Priority: P2    
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
patch
none
patch
none
patch kling: review+

Description Antti Koivisto 2016-03-06 01:03:31 PST
Mutating DOM from a renderer is bad.
Comment 1 Antti Koivisto 2016-03-06 01:18:45 PST
Created attachment 273130 [details]
patch
Comment 2 Antti Koivisto 2016-03-06 01:29:45 PST
Created attachment 273132 [details]
patch
Comment 3 WebKit Commit Bot 2016-03-06 01:32:15 PST
Attachment 273132 [details] did not pass style-queue:


ERROR: Source/WebCore/html/shadow/TextControlInnerElements.cpp:44:  Alphabetical sorting problem.  [build/include_order] [4]
ERROR: Source/WebCore/html/shadow/TextControlInnerElements.h:80:  "virtual" is redundant since function is already declared as "override"  [readability/inheritance] [4]
Total errors found: 2 in 9 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 4 Antti Koivisto 2016-03-06 01:35:09 PST
Created attachment 273133 [details]
patch
Comment 5 Andreas Kling 2016-03-06 02:02:41 PST
Comment on attachment 273133 [details]
patch

View in context: https://bugs.webkit.org/attachment.cgi?id=273133&action=review

r=me

> Source/WebCore/ChangeLog:10
> +        Text field placeholder element is currently managed by changing its inline style
> +        from the host renderer based on the host style and state. Rendering poking
> +        into DOM is wrong.

This is so weird.

> Source/WebCore/html/shadow/TextControlInnerElements.cpp:165
> +// ----------------------------

----------------------------

> Source/WebCore/html/shadow/TextControlInnerElements.h:78
> +    TextControlPlaceholderElement(Document&);

explicit
Comment 6 Antti Koivisto 2016-03-06 02:20:55 PST
http://trac.webkit.org/changeset/197637