Bug 155005

Summary: Remove "virtual" from all lines that have both "virtual" and "override"
Product: WebKit Reporter: Darin Adler <darin>
Component: WebKit Misc.Assignee: Darin Adler <darin>
Status: RESOLVED FIXED    
Severity: Normal CC: commit-queue, fred.wang, ggaren, mmaxfield, sbarati
Priority: P3    
Version: WebKit Nightly Build   
Hardware: All   
OS: All   
Attachments:
Description Flags
Patch
none
Patch ggaren: review+

Description Darin Adler 2016-03-03 19:56:12 PST
Remove "virtual" from all lines that have both "virtual" and "override".
Comment 1 Darin Adler 2016-03-03 20:02:42 PST
Created attachment 272821 [details]
Patch
Comment 2 Darin Adler 2016-03-03 20:03:27 PST
Wow, 3 MB patch.
Comment 3 Darin Adler 2016-03-03 20:06:38 PST
Comment on attachment 272821 [details]
Patch

Not sure why the patch doesn’t apply. Let me try to rebase.
Comment 4 Darin Adler 2016-03-03 20:08:56 PST
The content of attachment 272821 [details] has been deleted by
    Darin Adler <darin@apple.com>
without providing any reason.

The token used to delete this attachment was generated at 2016-03-03 20:08:53 PST.
Comment 5 Darin Adler 2016-03-03 20:09:59 PST
Created attachment 272822 [details]
Patch
Comment 6 WebKit Commit Bot 2016-03-03 20:12:43 PST
Attachment 272822 [details] did not pass style-queue:


ERROR: Source/WebKit2/UIProcess/DrawingAreaProxyImpl.h:56:  Extra space before ( in function call  [whitespace/parens] [4]
ERROR: Source/WebCore/platform/ios/WebVideoFullscreenInterfaceAVKit.h:77:  The parameter name "bufferedTime" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/WebKit2/UIProcess/API/C/WKPage.cpp:1778:  Extra space before ( in function call  [whitespace/parens] [4]
ERROR: Source/WebKit2/UIProcess/API/C/WKPage.cpp:1804:  Extra space before ( in function call  [whitespace/parens] [4]
ERROR: Source/WebKit2/UIProcess/API/C/WKPage.cpp:1831:  Extra space before ( in function call  [whitespace/parens] [4]
ERROR: Source/WebKit2/UIProcess/API/C/WKPage.cpp:2021:  Extra space before ( in function call  [whitespace/parens] [4]
ERROR: Source/WebKit2/UIProcess/API/C/WKPage.cpp:2046:  Extra space before ( in function call  [whitespace/parens] [4]
ERROR: Source/WebCore/html/HTMLLinkElement.h:87:  The parameter name "sheet" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/WebCore/inspector/InspectorCSSAgent.h:110:  The parameter name "pseudoIdMatches" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/WebCore/platform/graphics/avfoundation/objc/MediaPlayerPrivateMediaSourceAVFObjC.h:127:  The parameter name "volume" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/WebKit2/WebProcess/WebPage/mac/TiledCoreAnimationDrawingArea.h:80:  Extra space before ( in function call  [whitespace/parens] [4]
ERROR: Source/WTF/wtf/WorkQueue.h:72:  Extra space before ( in function call  [whitespace/parens] [4]
ERROR: Source/WebKit2/UIProcess/mac/TiledCoreAnimationDrawingAreaProxy.h:56:  Extra space before ( in function call  [whitespace/parens] [4]
WARNING: File exempt from style guide. Skipping: "Source/WebKit2/UIProcess/API/gtk/WebKitColorChooser.h"
ERROR: Source/WebCore/inspector/InspectorReplayAgent.h:107:  The parameter name "segmentState" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/WebCore/crypto/algorithms/CryptoAlgorithmHMAC.h:48:  The parameter name "data" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/WebKit2/UIProcess/mac/RemoteLayerTreeDrawingAreaProxy.h:64:  Extra space before ( in function call  [whitespace/parens] [4]
ERROR: Source/WebKit/mac/WebCoreSupport/WebInspectorClient.h:120:  The parameter name "height" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/WebCore/platform/graphics/transforms/SkewTransformOperation.h:49:  Tests for true/false, null/non-null, and zero/non-zero should all be done without equality comparisons.  [readability/comparison_to_zero] [5]
ERROR: Source/WebCore/platform/graphics/transforms/MatrixTransformOperation.h:54:  Tests for true/false, null/non-null, and zero/non-zero should all be done without equality comparisons.  [readability/comparison_to_zero] [5]
ERROR: Source/WebCore/platform/graphics/transforms/RotateTransformOperation.h:56:  Tests for true/false, null/non-null, and zero/non-zero should all be done without equality comparisons.  [readability/comparison_to_zero] [5]
ERROR: Source/WebKit2/UIProcess/API/gtk/WebKitUIClient.cpp:65:  Extra space before ( in function call  [whitespace/parens] [4]
ERROR: Source/WebKit2/UIProcess/API/gtk/WebKitUIClient.cpp:71:  Extra space before ( in function call  [whitespace/parens] [4]
ERROR: Source/WebKit2/UIProcess/API/gtk/WebKitUIClient.cpp:76:  Extra space before ( in function call  [whitespace/parens] [4]
ERROR: Source/WebKit2/UIProcess/API/gtk/WebKitUIClient.cpp:89:  Extra space before ( in function call  [whitespace/parens] [4]
ERROR: Source/WebKit2/UIProcess/API/gtk/WebKitUIClient.cpp:156:  Extra space before ( in function call  [whitespace/parens] [4]
ERROR: Source/WebCore/crypto/algorithms/CryptoAlgorithmRSASSA_PKCS1_v1_5.h:48:  The parameter name "data" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/WebKit2/UIProcess/Cocoa/UIDelegate.h:84:  Extra space before ( in function call  [whitespace/parens] [4]
ERROR: Source/WebKit2/UIProcess/Cocoa/UIDelegate.h:85:  Extra space before ( in function call  [whitespace/parens] [4]
ERROR: Source/WebKit2/UIProcess/Cocoa/UIDelegate.h:86:  Extra space before ( in function call  [whitespace/parens] [4]
ERROR: Source/WebKit2/UIProcess/Cocoa/UIDelegate.h:87:  Extra space before ( in function call  [whitespace/parens] [4]
ERROR: Source/WebKit2/UIProcess/Cocoa/UIDelegate.h:88:  Extra space before ( in function call  [whitespace/parens] [4]
Total errors found: 31 in 1432 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 7 Geoffrey Garen 2016-03-03 20:23:27 PST
Comment on attachment 272822 [details]
Patch

r=me
Comment 8 Darin Adler 2016-03-04 08:47:56 PST
Committed r197563: <http://trac.webkit.org/changeset/197563>
Comment 9 Darin Adler 2016-03-04 09:20:44 PST
Committed r197566: <http://trac.webkit.org/changeset/197566>
Comment 10 Myles C. Maxfield 2016-03-04 10:26:18 PST
Why is it beneficial to not have both virtual & override?
Comment 11 Darin Adler 2016-03-04 15:27:53 PST
Did you read either of the threads on webkit-dev about this? We discussed it at length. Antti originally suggested it.