Bug 153699

Summary: Web Inspector: Object tree parent items are misaligned
Product: WebKit Reporter: Devin Rousso <drousso>
Component: Web InspectorAssignee: Devin Rousso <drousso>
Status: RESOLVED FIXED    
Severity: Normal CC: bburg, commit-queue, graouts, joepeck, mattbaker, nvasilyev, timothy, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: All   
OS: All   
Attachments:
Description Flags
[Image] Issue
none
[Image] Another Issue
none
Patch
darin: review+
Patch none

Description Devin Rousso 2016-01-29 21:30:01 PST
Created attachment 270291 [details]
[Image] Issue

.
Comment 1 Radar WebKit Bug Importer 2016-01-29 21:30:18 PST
<rdar://problem/24423683>
Comment 2 Nikita Vasilyev 2016-01-29 21:31:51 PST
Steps to reproduce?
Is it a regression?
Comment 3 Devin Rousso 2016-01-29 21:39:25 PST
(In reply to comment #2)
> Steps to reproduce?
> Is it a regression?

I was debugging some Visual sidebar stuff and came across this.  Entering the following into the console and expand the first item:
WebInspector.cssStyleDetailsSidebarPanel._visualStyleDetailsPanel._groups.margin.properties.marginTop.style.properties

It seems like it may be a regression of the recent TreeOutline overhaul, but I'm investigating.
Comment 4 Devin Rousso 2016-01-29 21:43:07 PST
Created attachment 270294 [details]
[Image] Another Issue

Looks like I missed a testcase for <https://bugs.webkit.org/show_bug.cgi?id=153676>...
Comment 5 Devin Rousso 2016-01-29 21:47:31 PST
Created attachment 270295 [details]
Patch
Comment 6 Darin Adler 2016-01-30 11:28:13 PST
Comment on attachment 270295 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=270295&action=review

> Source/WebInspectorUI/ChangeLog:16
> +        This would apply to all .icon elements contained whithin a non-parent item,

Typo: within
Comment 7 Devin Rousso 2016-01-30 12:51:05 PST
Created attachment 270315 [details]
Patch
Comment 8 WebKit Commit Bot 2016-01-30 13:49:38 PST
Comment on attachment 270315 [details]
Patch

Clearing flags on attachment: 270315

Committed r195910: <http://trac.webkit.org/changeset/195910>
Comment 9 WebKit Commit Bot 2016-01-30 13:49:42 PST
All reviewed patches have been landed.  Closing bug.