Bug 153412

Summary: Web Inspector: Navigation bar in sidebars should always fit on a single line
Product: WebKit Reporter: Nikita Vasilyev <nvasilyev>
Component: Web InspectorAssignee: Devin Rousso <drousso>
Status: RESOLVED FIXED    
Severity: Normal CC: bburg, commit-queue, graouts, joepeck, mattbaker, nvasilyev, timothy, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: All   
OS: All   
Attachments:
Description Flags
[Animated GIF] Bug
none
[Animated GIF] Bug
none
Patch none

Description Nikita Vasilyev 2016-01-24 17:13:06 PST
Created attachment 269708 [details]
[Animated GIF] Bug

See the attached GIF.
Comment 1 Radar WebKit Bug Importer 2016-01-24 17:13:27 PST
<rdar://problem/24318706>
Comment 2 Matt Baker 2016-01-24 17:34:56 PST
Didn't Devin fix this for all sidebars? Since we're removing this sidebar in the Timelines UI redesign, I don't think we should invest any time fixing it, if the issue is specific to the TimelineSidebarPanel.
Comment 3 Nikita Vasilyev 2016-01-30 22:32:57 PST
Created attachment 270339 [details]
[Animated GIF] Bug

(In reply to comment #2)
> Didn't Devin fix this for all sidebars? ...

What was the bug URL?

Styles sidebar and debugger sidebar (with probes enabled) are both affected.

I can't reproduce it on Safari on OS X 10.11.3, so it's a regression.
Comment 4 Timothy Hatcher 2016-02-01 12:37:21 PST
Devin's fix was bug 152473.
Comment 5 Timothy Hatcher 2016-02-01 12:39:11 PST
From the animated GIF, it seems like there is contention between the minimum sidebar size and the maximum size. I suspect the maximum is smaller than the minimum, causing it to shrink when it is suppose to resize wider.
Comment 6 Devin Rousso 2016-02-02 21:59:58 PST
I have a bunch of classwork to finish up for next week, but I will take a look at this over the weekend.
Comment 7 Devin Rousso 2016-02-05 12:47:00 PST
Created attachment 270761 [details]
Patch
Comment 8 WebKit Commit Bot 2016-02-05 13:38:47 PST
Comment on attachment 270761 [details]
Patch

Clearing flags on attachment: 270761

Committed r196187: <http://trac.webkit.org/changeset/196187>
Comment 9 WebKit Commit Bot 2016-02-05 13:38:51 PST
All reviewed patches have been landed.  Closing bug.