Bug 15328

Summary: REGRESSION (r25534): Javascript Error at add an article in the basket on www.breathless.uk.com
Product: WebKit Reporter: Alexander Luck <xmenclassic>
Component: JavaScriptCoreAssignee: Nobody <webkit-unassigned>
Status: RESOLVED WORKSFORME    
Severity: Normal CC: ggaren, koivisto
Priority: P1 Keywords: HasReduction, InRadar, Regression
Version: 523.x (Safari 3)   
Hardware: All   
OS: All   
URL: http://www.breathless.uk.com
Attachments:
Description Flags
test case none

Description Alexander Luck 2007-09-30 09:01:27 PDT
At the shop www.Breathless.uk.com i can since r25545 not add a article in the basket the site. I see a error in the javascript console:

TypeError: Undefined value

With the nightly r25505 i can add a article in the basket the site.
Comment 1 David Kilzer (:ddkilzer) 2007-09-30 16:48:40 PDT
Internal revision search says:
Works: r25532  Fails: r25534

Since r25533 is a LayoutTests change, the regression occurred in r25534:
http://trac.webkit.org/projects/webkit/changeset/25534
Comment 2 Antti Koivisto 2007-11-06 22:24:45 PST
Created attachment 17093 [details]
test case

Added test case, PASSes match Firefox. 

In FF window.eval() seems to always put window to head of scope chain while plain eval() doesn't. Safari puts window to head of scope chain on eval when it is different than current global object.
Comment 3 David Kilzer (:ddkilzer) 2007-11-28 23:03:50 PST
<rdar://problem/5619362>
Comment 4 Alice Liu 2008-06-30 11:04:57 PDT
The JS error no longer occurs on TOT, and one can now add items to the shopping cart at this site.  moving the bug to resolved.