Bug 152497

Summary: Arrow functions: "this" isn't lexically bound
Product: WebKit Reporter: Nikita Vasilyev <nvasilyev>
Component: JavaScriptCoreAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: bburg, drousso, ggaren, gskachkov, mark.lam, sbarati, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
See Also: https://bugs.webkit.org/show_bug.cgi?id=152471
Bug Depends on:    
Bug Blocks: 140855    
Attachments:
Description Flags
[HTML] Reduction none

Description Nikita Vasilyev 2015-12-21 21:00:23 PST
Created attachment 267777 [details]
[HTML] Reduction

See the attached reduction.

It works well in Chrome stable (47.0.2526.106) and Firefox 45.0a2.
Comment 1 BJ Burg 2016-01-06 12:24:31 PST
*** Bug 152608 has been marked as a duplicate of this bug. ***
Comment 2 BJ Burg 2016-01-06 12:25:49 PST
+ JSC folks

Can this be investigated sooner than later? We already have at least two workarounds added in Web Inspector.
Comment 3 Radar WebKit Bug Importer 2016-01-06 12:29:12 PST
<rdar://problem/24077529>
Comment 4 GSkachkov 2016-01-06 13:00:45 PST
Looks like that it is the same bug as https://bugs.webkit.org/show_bug.cgi?id=152028, I already fixed it, but it was landed after later the last Webkit Night was build so I'll try to test soon on my local build.
Comment 5 GSkachkov 2016-01-06 14:22:21 PST
I've checked on my local build and I can't reproduce this bug. So I think it is already fixed.
Comment 6 BJ Burg 2016-01-07 08:07:20 PST
(In reply to comment #5)
> I've checked on my local build and I can't reproduce this bug. So I think it
> is already fixed.

OK, will re-open if we have another test case that fails.