Bug 152493

Summary: B3 should be able to compile Store16
Product: WebKit Reporter: Filip Pizlo <fpizlo>
Component: JavaScriptCoreAssignee: Filip Pizlo <fpizlo>
Status: RESOLVED FIXED    
Severity: Normal CC: barraclough, benjamin, commit-queue, ggaren, keith_miller, mark.lam, mhahnenb, msaboff, nrotem, oliver, saam, sam
Priority: P2    
Version: WebKit Nightly Build   
Hardware: All   
OS: All   
Bug Depends on:    
Bug Blocks: 150279    
Attachments:
Description Flags
the patch saam: review+

Description Filip Pizlo 2015-12-21 14:49:33 PST
Patch forthcoming.
Comment 1 Filip Pizlo 2015-12-21 15:02:25 PST
Created attachment 267763 [details]
the patch
Comment 2 WebKit Commit Bot 2015-12-21 15:04:10 PST
Attachment 267763 [details] did not pass style-queue:


ERROR: Source/JavaScriptCore/b3/testb3.cpp:4061:  Consider using CHECK_EQ instead of CHECK(a == b)  [readability/check] [2]
ERROR: Source/JavaScriptCore/b3/testb3.cpp:4062:  Consider using CHECK_EQ instead of CHECK(a == b)  [readability/check] [2]
ERROR: Source/JavaScriptCore/b3/testb3.cpp:4082:  Consider using CHECK_EQ instead of CHECK(a == b)  [readability/check] [2]
ERROR: Source/JavaScriptCore/b3/testb3.cpp:4083:  Consider using CHECK_EQ instead of CHECK(a == b)  [readability/check] [2]
ERROR: Source/JavaScriptCore/b3/testb3.cpp:4100:  Consider using CHECK_EQ instead of CHECK(a == b)  [readability/check] [2]
ERROR: Source/JavaScriptCore/b3/testb3.cpp:4101:  Consider using CHECK_EQ instead of CHECK(a == b)  [readability/check] [2]
ERROR: Source/JavaScriptCore/b3/testb3.cpp:4120:  Consider using CHECK_EQ instead of CHECK(a == b)  [readability/check] [2]
ERROR: Source/JavaScriptCore/b3/testb3.cpp:4121:  Consider using CHECK_EQ instead of CHECK(a == b)  [readability/check] [2]
Total errors found: 8 in 6 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 Saam Barati 2015-12-21 15:10:57 PST
Comment on attachment 267763 [details]
the patch

View in context: https://bugs.webkit.org/attachment.cgi?id=267763&action=review

r=me

> Source/JavaScriptCore/b3/testb3.cpp:4081
> +        int8_t storage = -1;

This should be int16_t
Comment 4 Filip Pizlo 2015-12-21 15:41:28 PST
Landed in http://trac.webkit.org/changeset/194354
Comment 5 Filip Pizlo 2015-12-21 15:50:27 PST
(In reply to comment #3)
> Comment on attachment 267763 [details]
> the patch
> 
> View in context:
> https://bugs.webkit.org/attachment.cgi?id=267763&action=review
> 
> r=me
> 
> > Source/JavaScriptCore/b3/testb3.cpp:4081
> > +        int8_t storage = -1;
> 
> This should be int16_t

Landed in http://trac.webkit.org/changeset/194355