Bug 151616

Summary: Fix the !ENABLE(DFG_JIT) build after r192699
Product: WebKit Reporter: Csaba Osztrogonác <ossy>
Component: JavaScriptCoreAssignee: Csaba Osztrogonác <ossy>
Status: RESOLVED FIXED    
Severity: Critical CC: commit-queue, fpizlo, ggaren, keith_miller, mark.lam, msaboff, sbarati
Priority: P1    
Version: Other   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on:    
Bug Blocks: 150762    
Attachments:
Description Flags
Patch none

Description Csaba Osztrogonác 2015-11-26 04:15:45 PST
build error log:
-----------------

../../Source/JavaScriptCore/assembler/MacroAssembler.h: In member function 'void JSC::MacroAssembler::moveDoubleConditionallyTest32(JSC::MacroAssemblerX86Common::ResultCondition, TestType, MaskType, JSC::AbstractMacroAssembler<JSC::X86Assembler, JSC::MacroAssemblerX86Common>::FPRegisterID, JSC::AbstractMacroAssembler<JSC::X86Assembler, JSC::MacroAssemblerX86Common>::FPRegisterID)':
../../Source/JavaScriptCore/assembler/MacroAssembler.h:1323:30: error: there are no arguments to 'isInvertible' that depend on a template parameter, so a declaration of 'isInvertible' must be available [-fpermissive]
../../Source/JavaScriptCore/assembler/MacroAssembler.h:1323:30: note: (if you use '-fpermissive', G++ will accept your code, but allowing the use of an undeclared name is deprecated)
../../Source/JavaScriptCore/assembler/MacroAssembler.h:1324:54: error: no matching function for call to 'JSC::MacroAssembler::invert(JSC::MacroAssemblerX86Common::ResultCondition&)'

The problem is that isInvertible() is defined inside ENABLE(DFG_JIT) guards, but used without guard:
- http://trac.webkit.org/browser/trunk/Source/JavaScriptCore/assembler/MacroAssembler.h?rev=192699#L175
- http://trac.webkit.org/changeset/192699/trunk/Source/JavaScriptCore/assembler/MacroAssembler.h

But the new moveDoubleConditionally*() functions are used only in B3 JIT, let's guard them.
Comment 1 Csaba Osztrogonác 2015-11-26 04:16:59 PST
Created attachment 266176 [details]
Patch
Comment 2 WebKit Commit Bot 2015-11-30 22:58:57 PST
Comment on attachment 266176 [details]
Patch

Clearing flags on attachment: 266176

Committed r192862: <http://trac.webkit.org/changeset/192862>
Comment 3 WebKit Commit Bot 2015-11-30 22:59:02 PST
All reviewed patches have been landed.  Closing bug.