Bug 151125

Summary: Add features requested by 1Password to WebCrypto
Product: WebKit Reporter: Ryosuke Niwa <rniwa>
Component: WebCore Misc.Assignee: Nobody <webkit-unassigned>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: ap, bfulgham, elima, jiewen_tan, mail, oliver, rob, roustem
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
URL: https://twitter.com/ryosukeniwa/status/664286585593049088
See Also: https://bugs.webkit.org/show_bug.cgi?id=157175
Bug Depends on: 160880    
Bug Blocks:    

Description Ryosuke Niwa 2015-11-10 19:44:30 PST
The list of features being requested:
https://gist.github.com/roustem/5113d48e1a91e220ff6d

It looks like they need at least AES-GCM.
Comment 1 Alexey Proskuryakov 2015-11-10 20:04:02 PST
rdar://problem/23379153
Comment 2 Roustem 2016-01-16 14:28:05 PST
We polyfilled AES-GCM using SCJL in 1Password. The biggest show stopper is RSA-OAEP-256.
Comment 3 Tankred Hase 2016-03-23 20:50:35 PDT
I'm currently implementing AES-GCM support for OpenPGP.js (IETF draft):

https://github.com/openpgpjs/openpgpjs/pull/430

Having native support in WebKit would make a big difference for larger files on iOS:

https://github.com/openpgpjs/openpgpjs/pull/430#issuecomment-200469142

I'd happily help with testing if I can. Thanks for your consideration!
Comment 4 Rob 2016-11-11 13:01:59 PST
Just to update here, Jiewen Tan's recent work to update `importKey` to the latest spec (https://bugs.webkit.org/show_bug.cgi?id=164446) fixes half of our (1Password's) problems with WebKit. In the latest WebKit nightly, it's now possible to sign in to accounts that were created with RSA-OAEP-256 keys. The biggest remaining issue here without a workaround is fixing `exportKey` https://bugs.webkit.org/show_bug.cgi?id=156114. AES-GCM would be great too so we can avoid polyfilling it (https://bugs.webkit.org/show_bug.cgi?id=157175).
Comment 5 Jiewen Tan 2017-01-03 14:35:19 PST
Duplicate this bug to Bug 157175 since the only remaining request from 1Password is to add AES-GCM.

*** This bug has been marked as a duplicate of bug 157175 ***