Bug 150867

Summary: [Win] streams/reference-implementation/writable-stream-abort.html is failing
Product: WebKit Reporter: Ryan Haddad <ryanhaddad>
Component: New BugsAssignee: Xabier Rodríguez Calvar <calvaris>
Status: RESOLVED DUPLICATE    
Severity: Normal    
Priority: P2    
Version: WebKit Nightly Build   
Hardware: PC   
OS: Windows 7   

Description Ryan Haddad 2015-11-03 16:10:33 PST
[Win] streams/reference-implementation/writable-stream-abort.html is failing

Run:
<https://build.webkit.org/builders/Apple%20Win%207%20Release%20%28Tests%29/builds/54903>
Results:
<https://build.webkit.org/results/Apple%20Win%207%20Release%20(Tests)/r191978%20(54903)/results.html>

--- /home/buildbot/slave/win-release-tests/build/layout-test-results/streams/reference-implementation/writable-stream-abort-expected.txt
+++ /home/buildbot/slave/win-release-tests/build/layout-test-results/streams/reference-implementation/writable-stream-abort-actual.txt
@@ -1,6 +1,6 @@
 
 PASS Aborting a WritableStream immediately prevents future writes 
-PASS Aborting a WritableStream prevents further writes after any that are in progress 
+FAIL Aborting a WritableStream prevents further writes after any that are in progress assert_array_equals: only the single in-progress chunk gets written lengths differ, expected 1 got 0
 PASS Fulfillment value of ws.abort() call must be undefined even if the underlying sink returns a non-undefined value 
 PASS WritableStream if sink's abort throws, the promise returned by ws.abort() rejects 
 PASS Aborting a WritableStream passes through the given reason
Comment 1 Ryan Haddad 2015-11-03 16:12:42 PST
Marked as flaky in win TestExpectations with r191992.
Comment 2 Xabier Rodríguez Calvar 2015-11-04 01:36:42 PST
Marked as duplicate of bug 147933, changed the referred bug at https://trac.webkit.org/changeset/192018

*** This bug has been marked as a duplicate of bug 147933 ***