Bug 150862

Summary: Web Inspector: REGRESSION (r191612): Storage sidebar panel tree outline is broken
Product: WebKit Reporter: Matt Baker <mattbaker>
Component: Web InspectorAssignee: Matt Baker <mattbaker>
Status: RESOLVED FIXED    
Severity: Normal CC: bburg, commit-queue, graouts, joepeck, mattbaker, nvasilyev, timothy, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: All   
OS: All   
Attachments:
Description Flags
[Patch] Proposed Fix none

Description Matt Baker 2015-11-03 15:42:11 PST
* SUMMARY
Storage sidebar panel tree outline is broken. Calling append() instead of appendChild() on database and application cache tree elements.

Regressed in: http://trac.webkit.org/changeset/191612.
Comment 1 Radar WebKit Bug Importer 2015-11-03 15:42:49 PST
<rdar://problem/23383951>
Comment 2 Matt Baker 2015-11-03 15:58:28 PST
The app cache UI is still broken after fixing the regression because ApplicationCacheFrameContentView inherits from the wrong base class (regressed in http://trac.webkit.org/changeset/187967).

Simply changing the base class to ContentView fixes the issue, so I'll roll that into this patch.
Comment 3 Matt Baker 2015-11-03 16:02:49 PST
Created attachment 264746 [details]
[Patch] Proposed Fix
Comment 4 Joseph Pecoraro 2015-11-03 17:01:41 PST
Comment on attachment 264746 [details]
[Patch] Proposed Fix

View in context: https://bugs.webkit.org/attachment.cgi?id=264746&action=review

r=me

> Source/WebInspectorUI/UserInterface/Views/ApplicationCacheFrameContentView.js:26
> -WebInspector.ApplicationCacheFrameContentView = class ApplicationCacheFrameContentView extends WebInspector.ApplicationCacheFrame
> +WebInspector.ApplicationCacheFrameContentView = class ApplicationCacheFrameContentView extends WebInspector.ContentView

Great find.
Comment 5 WebKit Commit Bot 2015-11-03 17:49:40 PST
Comment on attachment 264746 [details]
[Patch] Proposed Fix

Clearing flags on attachment: 264746

Committed r192005: <http://trac.webkit.org/changeset/192005>
Comment 6 WebKit Commit Bot 2015-11-03 17:49:44 PST
All reviewed patches have been landed.  Closing bug.