Bug 149390

Summary: Web Inspector: requestAnimationFrame continues to be called after stopping the timeline recording
Product: WebKit Reporter: Matt Baker <mattbaker>
Component: Web InspectorAssignee: Matt Baker <mattbaker>
Status: RESOLVED FIXED    
Severity: Normal CC: bburg, commit-queue, graouts, joepeck, mattbaker, nvasilyev, timothy, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: All   
OS: All   
Attachments:
Description Flags
[Patch] Proposed Fix none

Description Matt Baker 2015-09-20 14:00:34 PDT
* SUMMARY
requestAnimationFrame continues to be called after stopping the timeline recording. This only happens if no records are added to the recording.

* STEPS TO REPRODUCE
1. Open Inspector > Timelines
2. Inspect the Inspector
3. Set a logging breakpoint in TimelineRecordingContentView's _update method.
4. Press 'Start Recording' button (don't reload Inspected page)
5. Don't take any actions on inspected page (don't generate any timeline records)
6. Stop recording
  => Update messages continue to be logged to the console in Inspector²

* NOTES
TimelineRecordingContentView correctly sets "_updating" to false, but the animation frame callback will continue to self register until the recording start time is >= the end time. Since no records were added to the recording, the end time is NaN and the test always fails.
Comment 1 Radar WebKit Bug Importer 2015-09-20 14:00:56 PDT
<rdar://problem/22774849>
Comment 2 Matt Baker 2015-09-20 14:05:26 PDT
Created attachment 261612 [details]
[Patch] Proposed Fix
Comment 3 BJ Burg 2015-09-21 08:43:12 PDT
Comment on attachment 261612 [details]
[Patch] Proposed Fix

r=me
Comment 4 WebKit Commit Bot 2015-09-21 09:30:41 PDT
Comment on attachment 261612 [details]
[Patch] Proposed Fix

Clearing flags on attachment: 261612

Committed r190058: <http://trac.webkit.org/changeset/190058>
Comment 5 WebKit Commit Bot 2015-09-21 09:30:44 PDT
All reviewed patches have been landed.  Closing bug.