Bug 14930

Summary: REGRESSION: Extra text shown in gmail in Safari versus FF/IE
Product: WebKit Reporter: Cameo Wood <cameo.wood>
Component: Layout and RenderingAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: aroben, dev+webkit, mitz
Priority: P1 Keywords: GoogleBug, InRadar, NeedsReduction, Regression
Version: 523.x (Safari 3)   
Hardware: All   
OS: All   
URL: https://gmail.com
Attachments:
Description Flags
This is how the email renders in FF
none
This is how the same email renders in WinSafari none

Description Cameo Wood 2007-08-10 10:56:05 PDT
For some reason, Safari includes text from Bugzilla reports in gmail past the -Show quoted text- signifier that does not show up in FF.  

in FF, no text is shown after the gmail-inserted "-show quoted text-" however, in WinSafari, I get the text 

"
fs.cgi?tab=email ** Which links to http://bugs.webkit.org/userprefs.cgi?tab=email
-----You are recieving this mail because: ---- 
You reported the bug, or are watching the reporter.
"

Even though the link isn't fully shown in the email, it does work as you can see in the image of the url in the status bar from hovering over "fs.cgi?tab=email"

I am running 3.0.3 with the lately nightly.
Comment 1 Cameo Wood 2007-08-10 10:56:47 PDT
Created attachment 15912 [details]
This is how the email renders in FF
Comment 2 Cameo Wood 2007-08-10 10:57:16 PDT
Created attachment 15913 [details]
This is how the same email renders in WinSafari
Comment 3 Adam Roben (:aroben) 2007-08-10 11:13:27 PDT
Does anyone know if this happens on OS X as well?
Comment 4 Matt Lilek 2007-08-10 16:27:51 PDT
(In reply to comment #3)
> Does anyone know if this happens on OS X as well?
> 

This does indeed happen on OS X and is a regression from Safari 2.0.4.
Comment 5 David Kilzer (:ddkilzer) 2007-08-11 06:57:09 PDT
<rdar://problem/5404061>