Bug 149259

Summary: REGRESSION: Web Inspector: Double clicking on an attribute second time doesn't work
Product: WebKit Reporter: Nikita Vasilyev <nvasilyev>
Component: Web InspectorAssignee: Joseph Pecoraro <joepeck>
Status: RESOLVED FIXED    
Severity: Normal CC: bburg, commit-queue, graouts, joepeck, mattbaker, nvasilyev, timothy, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: WebKit Local Build   
Hardware: All   
OS: All   
Attachments:
Description Flags
[Animated GIF] Bug
none
[PATCH] Proposed Fix none

Description Nikita Vasilyev 2015-09-17 06:14:00 PDT
Created attachment 261389 [details]
[Animated GIF] Bug

Steps:
1. Open http://nightly.webkit.org/start/trunk/189906
2. Inspect <div id="frame"> (or any other element with an attribute)
3. Double click on id="frame"
4. Click on some other element
5. Double click on id="frame" again

Expected:
Double clicking the second time enters the editing mode, the same as the first time.

Actual:
It doesn't enter the editing mode.
Comment 1 Radar WebKit Bug Importer 2015-09-17 06:14:14 PDT
<rdar://problem/22737913>
Comment 2 Joseph Pecoraro 2015-09-17 13:14:26 PDT
We are bailing because DOMTreeElement.prototype.ondblclick thinks we are still editing.
Comment 3 Joseph Pecoraro 2015-09-17 13:32:11 PDT
Created attachment 261415 [details]
[PATCH] Proposed Fix
Comment 4 WebKit Commit Bot 2015-09-17 14:26:49 PDT
Comment on attachment 261415 [details]
[PATCH] Proposed Fix

Clearing flags on attachment: 261415

Committed r189933: <http://trac.webkit.org/changeset/189933>
Comment 5 WebKit Commit Bot 2015-09-17 14:26:53 PDT
All reviewed patches have been landed.  Closing bug.