Bug 149153

Summary: REGRESSION(r155554): Nested isolates can cause an infinite loop when laying out bidi runs
Product: WebKit Reporter: Myles C. Maxfield <mmaxfield>
Component: New BugsAssignee: Myles C. Maxfield <mmaxfield>
Status: RESOLVED FIXED    
Severity: Normal CC: dino, hartman.wiki, hyatt, jonlee, kojiishi, simon.fraser, thorton
Priority: P2    
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on: 149193    
Bug Blocks:    
Attachments:
Description Flags
Patch hyatt: review+

Description Myles C. Maxfield 2015-09-14 23:13:35 PDT
Nested isolates can cause an infinite loop when laying out bidi runs
Comment 1 Myles C. Maxfield 2015-09-14 23:35:52 PDT
Created attachment 261178 [details]
Patch
Comment 2 Dave Hyatt 2015-09-15 09:36:53 PDT
Comment on attachment 261178 [details]
Patch

r=me, but check with someone who cares about WTF naming conventions etc. and make sure they are cool with Void.h
Comment 3 Myles C. Maxfield 2015-09-15 11:08:10 PDT
Comment on attachment 261178 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=261178&action=review

> Source/WTF/wtf/Void.h:32
> +class Void {

Anders says this is bad.
Comment 4 Myles C. Maxfield 2015-09-15 17:30:53 PDT
Committed r189832: <http://trac.webkit.org/changeset/189832>
Comment 5 Simon Fraser (smfr) 2015-09-15 17:48:53 PDT
The changelog failed to explain when this was introduced.
Comment 6 Myles C. Maxfield 2015-09-16 14:06:32 PDT
(In reply to comment #5)
> The changelog failed to explain when this was introduced.

Updated ChangeLog committed r189880
Comment 7 Brent Fulgham 2016-07-15 09:40:08 PDT
*** Bug 148573 has been marked as a duplicate of this bug. ***