Bug 148936

Summary: [GTK] Some tests at http/tests/w3c/html/semantics/ fail
Product: WebKit Reporter: Carlos Alberto Lopez Perez <clopez>
Component: WebKitGTKAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: bugs-noreply, mcatanzaro, pnormand
Priority: P2    
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   

Description Carlos Alberto Lopez Perez 2015-09-07 11:23:21 PDT
Some of the tests at http/tests/w3c/html/semantics/ fail on the GTK+ port.
This tests were imported in bug 14882

The failures are:

Regressions: Unexpected text-only failures (17)
  http/tests/w3c/html/semantics/embedded-content/media-elements/loading-the-media-resource/resource-selection-pointer-control.html [ Failure ]
  http/tests/w3c/html/semantics/embedded-content/media-elements/loading-the-media-resource/resource-selection-pointer-insert-br.html [ Failure ]
  http/tests/w3c/html/semantics/embedded-content/media-elements/loading-the-media-resource/resource-selection-pointer-insert-source.html [ Failure ]
  http/tests/w3c/html/semantics/embedded-content/media-elements/loading-the-media-resource/resource-selection-pointer-insert-text.html [ Failure ]
  http/tests/w3c/html/semantics/embedded-content/media-elements/loading-the-media-resource/resource-selection-pointer-remove-source-after.html [ Failure ]
  http/tests/w3c/html/semantics/embedded-content/media-elements/loading-the-media-resource/resource-selection-pointer-remove-source.html [ Failure ]
  http/tests/w3c/html/semantics/embedded-content/media-elements/loading-the-media-resource/resource-selection-pointer-remove-text.html [ Failure ]
  http/tests/w3c/html/semantics/embedded-content/media-elements/mime-types/canPlayType.html [ Failure ]
  http/tests/w3c/html/semantics/embedded-content/the-img-element/sizes/parse-a-sizes-attribute.html [ Failure ]
  http/tests/w3c/html/semantics/embedded-content/the-img-element/srcset/parse-a-srcset-attribute.html [ Failure ]
  http/tests/w3c/html/semantics/embedded-content/the-img-element/srcset/select-an-image-source.html [ Failure ]
  http/tests/w3c/html/semantics/embedded-content/the-img-element/update-the-source-set.html [ Failure ]
  http/tests/w3c/html/semantics/forms/textfieldselection/textfieldselection-setSelectionRange.html [ Failure ]
  http/tests/w3c/html/semantics/forms/the-form-element/form-autocomplete.html [ Failure ]
  http/tests/w3c/html/semantics/forms/the-input-element/telephone.html [ Failure ]
  http/tests/w3c/html/semantics/interactive-elements/the-dialog-element/dialog-showModal.html [ Failure ]
  http/tests/w3c/html/semantics/selectors/pseudo-classes/focus.html [ Failure ]
Comment 1 Carlos Alberto Lopez Perez 2015-09-08 08:37:42 PDT
The first 7 tests were removed on r189480
Comment 2 Michael Catanzaro 2016-02-06 08:18:15 PST
The following tests:

imported/w3c/web-platform-tests/html/semantics/embedded-content/the-img-element/srcset/parse-a-srcset-attribute.html
imported/w3c/web-platform-tests/html/semantics/embedded-content/the-img-element/srcset/select-an-image-source.html
imported/w3c/web-platform-tests/html/semantics/embedded-content/the-img-element/update-the-source-set.html

have been passing since r192953.
Comment 3 Michael Catanzaro 2016-05-15 14:54:38 PDT
(In reply to comment #0)
>   http/tests/w3c/html/semantics/selectors/pseudo-classes/focus.html [
> Failure ]

This one is passing since r200309.
Comment 4 Michael Catanzaro 2016-05-15 15:07:04 PDT
Updated expectations in r200929.
Comment 5 Michael Catanzaro 2016-05-15 17:09:48 PDT
(In reply to comment #4)
> Updated expectations in r200929.

Just kidding, really updated in r200935.
Comment 6 Philippe Normand 2019-04-10 04:31:47 PDT
The last test flagged here:

imported/w3c/web-platform-tests/html/semantics/embedded-content/media-elements/mime-types/canPlayType.html

Should now pass thanks to the patch in bug 196615.