Bug 148815

Summary: column-rule-style: outset/inset doesn't work
Product: WebKit Reporter: Ryosuke Niwa <rniwa>
Component: Layout and RenderingAssignee: zalan <zalan>
Status: RESOLVED FIXED    
Severity: Normal CC: bdakin, commit-queue, esprehn+autocc, glenn, hyatt, kondapallykalyan, mcatanzaro, webkit-bug-importer, zalan
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on:    
Bug Blocks: 148813    
Attachments:
Description Flags
Patch none

Description Ryosuke Niwa 2015-09-04 13:01:34 PDT
column-rule-style: outset/inset doesn't seem to work according to the newly imported tests: 
imported/w3c/css/css-multicol-1/multicol-rule-style-outset-001.xht
imported/w3c/css/css-multicol-1/multicol-rule-style-inset-001.xht
Comment 1 Radar WebKit Bug Importer 2015-09-04 13:02:35 PDT
<rdar://problem/22582644>
Comment 2 zalan 2015-09-16 11:44:00 PDT
Outset seems to be painted properly. However the reference test seems somewhat odd with display: table and border collapsing on. (which produces the double stripes).
I am not sure what the intention was with this reference setup.
Comment 3 zalan 2015-09-16 11:47:50 PDT
(In reply to comment #2)
> Outset seems to be painted properly. However the reference test seems
> somewhat odd with display: table and border collapsing on. (which produces
> the double stripes).
> I am not sure what the intention was with this reference setup.
Oh, it's because of this: "'border-style' values of column-rule are interpreted as in the collapsing border model in which case 'inset' value is drawn the same as 'ridge'.
"
Comment 4 zalan 2015-09-16 15:13:49 PDT
Created attachment 261331 [details]
Patch
Comment 5 zalan 2015-09-16 15:14:04 PDT
*** Bug 148811 has been marked as a duplicate of this bug. ***
Comment 6 Dave Hyatt 2015-09-17 08:56:02 PDT
Comment on attachment 261331 [details]
Patch

r=me
Comment 7 WebKit Commit Bot 2015-09-17 10:03:42 PDT
Comment on attachment 261331 [details]
Patch

Clearing flags on attachment: 261331

Committed r189916: <http://trac.webkit.org/changeset/189916>
Comment 8 WebKit Commit Bot 2015-09-17 10:03:48 PDT
All reviewed patches have been landed.  Closing bug.
Comment 9 Michael Catanzaro 2016-01-06 17:36:09 PST
These tests:

imported/w3c/css/css-multicol-1/multicol-rule-inset-000.xht [ ImageOnlyFailure ]
imported/w3c/css/css-multicol-1/multicol-rule-outset-000.xht [ ImageOnlyFailure ]

Are still failing on the GTK port, see bug #152823.