Bug 148811

Summary: border-style' values of column-rule are interpreted as in the collapsing border model in which case 'inset' value is drawn the same as 'ridge'
Product: WebKit Reporter: Ryosuke Niwa <rniwa>
Component: Layout and RenderingAssignee: Nobody <webkit-unassigned>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: bdakin, hyatt, mmaxfield, webkit-bug-importer, zalan
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on:    
Bug Blocks: 148813    

Description Ryosuke Niwa 2015-09-04 12:22:13 PDT
'border-style' values of column-rule are interpreted as in the collapsing border model in which case 'inset' value is drawn the same as 'ridge'.

This bug was found by the test: LayoutTests/imported/w3c/css/css-multicol-1/multicol-rule-inset-000.xht.
which was written by HÃ¥kon Wium Lie who was the author of the multicolumn layout mode spec.
Comment 1 Radar WebKit Bug Importer 2015-09-04 12:22:48 PDT
<rdar://problem/22582086>
Comment 2 Ryosuke Niwa 2015-09-04 12:23:19 PDT
multicol-rule-outset-000.xht also fails:

'border-style' values of column-rule are interpreted as in the collapsing border model in which case 'outset' value is drawn the same as 'groove'.
Comment 3 zalan 2015-09-16 15:14:04 PDT

*** This bug has been marked as a duplicate of bug 148815 ***