Bug 148195

Summary: Standalone image documents should send their size to the UIClient just like standalone media documents
Product: WebKit Reporter: Beth Dakin <bdakin>
Component: WebKit2Assignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: achristensen, bdakin, calvaris, cgarcia, commit-queue, esprehn+autocc, gyuyoung.kim, ossy, thorton
Priority: P2    
Version: Other   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on: 148279, 148424    
Bug Blocks:    
Attachments:
Description Flags
Patch
none
Patch thorton: review+

Description Beth Dakin 2015-08-19 15:00:56 PDT
Standalone image documents should send their size to the UIClient just like standalone media documents

rdar://problem/21951253
Comment 1 Beth Dakin 2015-08-19 15:04:16 PDT
Created attachment 259410 [details]
Patch
Comment 2 Beth Dakin 2015-08-19 15:43:31 PDT
Created attachment 259420 [details]
Patch
Comment 3 Tim Horton 2015-08-19 15:48:21 PDT
Comment on attachment 259420 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=259420&action=review

> Source/WebCore/page/ChromeClient.h:459
> +    virtual void imageDocumentSizeChanged(const WebCore::IntSize&) { }
>  #if ENABLE(VIDEO)
>      virtual void mediaDocumentNaturalSizeChanged(const WebCore::IntSize&) { }

Any reason these aren't combined?
Comment 4 Beth Dakin 2015-08-20 11:46:44 PDT
Thanks Tim! http://trac.webkit.org/changeset/188693
Comment 5 Xabier Rodríguez Calvar 2015-08-21 01:58:21 PDT
This commit is breaking (at least) GTK+ compilation.
Comment 6 Beth Dakin 2015-08-21 10:42:05 PDT
(In reply to comment #5)
> This commit is breaking (at least) GTK+ compilation.

Do you have a build failure log?
Comment 7 Xabier Rodríguez Calvar 2015-08-24 01:16:05 PDT
(In reply to comment #6)
> (In reply to comment #5)
> > This commit is breaking (at least) GTK+ compilation.
> 
> Do you have a build failure log?

It seems that this problem got fixed somehow. Now the problem is another unrelated one.
Comment 8 Csaba Osztrogonác 2015-08-26 01:43:44 PDT
Just to document, the EFL build was fixed by https://trac.webkit.org/changeset/188738 and the GTK was fixed by https://trac.webkit.org/changeset/188740