Bug 146324

Summary: [Mac] Web Inspector: Window dragging on toolbar should behave more like native window dragging
Product: WebKit Reporter: Joseph Pecoraro <joepeck>
Component: Web InspectorAssignee: Joseph Pecoraro <joepeck>
Status: RESOLVED FIXED    
Severity: Normal CC: commit-queue, graouts, joepeck, jonowells, mattbaker, matt.yohe, nvasilyev, timothy, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: 528+ (Nightly build)   
Hardware: All   
OS: All   
Attachments:
Description Flags
[PATCH] Proposed Fix
joepeck: commit-queue-
[PATCH] Proposed Fix timothy: review+

Description Joseph Pecoraro 2015-06-25 14:39:24 PDT
* SUMMARY
[Mac] Web Inspector: Window dragging on toolbar should behave more like native window dragging

* STEPS TO REPRODUCE
1. Open Inspector detached
2. Drag window from toolbar (under top 22pt)
3. Drag window all the way to the top of the screen
4. Drag window down from the top
  => Not seeing native window dragging behavior
Comment 1 Joseph Pecoraro 2015-06-25 14:39:36 PDT
<rdar://problem/21549315>
Comment 2 Joseph Pecoraro 2015-06-25 15:03:29 PDT
Created attachment 255577 [details]
[PATCH] Proposed Fix

cq- while I build and test on another machine.
Comment 3 WebKit Commit Bot 2015-06-25 15:06:56 PDT
Attachment 255577 [details] did not pass style-queue:


ERROR: Source/WebCore/ChangeLog:8:  You should remove the 'No new tests' and either add and list tests, or explain why no new tests were possible.  [changelog/nonewtests] [5]
Total errors found: 1 in 23 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 4 Joseph Pecoraro 2015-06-25 15:52:16 PDT
Created attachment 255583 [details]
[PATCH] Proposed Fix
Comment 5 Joseph Pecoraro 2015-06-25 16:00:17 PDT
*** Bug 110358 has been marked as a duplicate of this bug. ***
Comment 6 Joseph Pecoraro 2015-06-25 16:11:15 PDT
http://trac.webkit.org/changeset/185968
Comment 7 Joseph Pecoraro 2015-06-25 19:31:53 PDT
iOS build fix: http://trac.webkit.org/changeset/185979