Bug 146182

Summary: editing/selection/leak-document-with-selection-inside.html is flaky
Product: WebKit Reporter: David Kilzer (:ddkilzer) <ddkilzer>
Component: Tools / TestsAssignee: Nobody <webkit-unassigned>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: Hironori.Fujii, rniwa, webkit-bug-importer
Priority: P2 Keywords: InRadar, LayoutTestFailure
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on: 119122    
Bug Blocks:    

Description David Kilzer (:ddkilzer) 2015-06-20 09:05:19 PDT
editing/selection/leak-document-with-selection-inside.html is flaky on most platforms, and fails on both Release and Debug bots for Apple Win 7.

Per the Flakiness Dashboard, this test appears to have started flaking more in the last month or so (June 2015):
<https://webkit-test-results.appspot.com/dashboards/flakiness_dashboard.html#showAllRuns=true&revision=185721&tests=editing%2Fselection%2Fleak-document-with-selection-inside.html>

The test relies on garbage collection and a zero-delay timer.

Previous attempt to fix flakiness: <http://trac.webkit.org/r153498>

Test originally added by:
Bug 119122: REGRESSION(r139282): Fix document leak when selection is created inside the document
<https://bugs.webkit.org/show_bug.cgi?id=119122>
<http://trac.webkit.org/changeset/153366>
Comment 1 David Kilzer (:ddkilzer) 2015-06-20 09:11:36 PDT
Hmm...the Flakiness Dashboard says the test always fails on Apple Win 7 Release/Debug, but I don't see the failures on individual test runs.
Comment 2 David Kilzer (:ddkilzer) 2015-06-20 09:17:20 PDT
Marked test as flaky: <http://trac.webkit.org/r185796>
Comment 3 Ryosuke Niwa 2015-06-21 19:04:17 PDT
I think GCController.gc() doesn't always collect all the objects :(  We need to figure out why.
Comment 4 Fujii Hironori 2022-07-12 05:02:34 PDT
Fixed by 252375@main.
Comment 5 Radar WebKit Bug Importer 2022-07-12 05:03:21 PDT
<rdar://problem/96878268>
Comment 6 David Kilzer (:ddkilzer) 2022-07-12 10:43:57 PDT

*** This bug has been marked as a duplicate of bug 242585 ***