Bug 14583

Summary: [GDK] file:// relative CSS include URLs handled incorrectly
Product: WebKit Reporter: Alp Toker <alp>
Component: New BugsAssignee: Nobody <webkit-unassigned>
Status: RESOLVED DUPLICATE    
Severity: Normal Keywords: Curl, Gtk
Priority: P2    
Version: 523.x (Safari 3)   
Hardware: All   
OS: All   
Attachments:
Description Flags
Test case none

Description Alp Toker 2007-07-11 08:26:21 PDT
When linking to a CSS stylesheet in a subdirectory ("styles/style.css"), if that CSS file imports "style2.css" (@import url(style2.css);) WebKit/Gtk+ looks for style2.css in the same directory as the original HTML file.

The expected behaviour (seen in Firefox, WebKit/Mac and WebKit/Gtk+ using the http:// backend) would be for it to load "styles/style2.css", not "style2.css".
Comment 1 Alp Toker 2007-07-11 08:27:41 PDT
Created attachment 15473 [details]
Test case

This test case has a red background to indicate broken behaviour, or a green background to indicate correct behaviour.
Comment 2 Holger Freyther 2007-09-10 13:39:22 PDT
This is a issue with the CURL implementation of ResourceHandle,ResourceHandleManager.
Comment 3 Alp Toker 2007-12-08 06:48:10 PST

*** This bug has been marked as a duplicate of 14651 ***