Bug 144979

Summary: Implement lexical scoping in sloppy mode
Product: WebKit Reporter: Saam Barati <sbarati>
Component: JavaScriptCoreAssignee: Saam Barati <sbarati>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: fpizlo, ggaren, mark.lam, mmirman, msaboff, oliver
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on: 142944    
Bug Blocks:    

Description Saam Barati 2015-05-13 18:16:26 PDT
This will break programs that previously worked. But it seems like something
that should be done sooner rather than later. I think the current implementation
should "Just Work" but will need to be tested with language features that are
disabled in strict mode.
Comment 1 Saam Barati 2015-07-09 17:59:24 PDT

*** This bug has been marked as a duplicate of bug 142944 ***