Bug 144258

Summary: Redefining a method of the same name hits an assertion
Product: WebKit Reporter: Ryosuke Niwa <rniwa>
Component: JavaScriptCoreAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: joepeck, mark.lam, ossy, rniwa, sbarati
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on:    
Bug Blocks: 140491    
Attachments:
Description Flags
[PATCH] Proposed Fix - Unskip rniwa: review+

Description Ryosuke Niwa 2015-04-27 03:11:40 PDT
class A { get foo() {} get foo() {} } hits an assertion.
Comment 1 Csaba Osztrogon√°c 2015-04-27 03:21:22 PDT
re https://trac.webkit.org/changeset/183391 - run-javascriptcore-tests doesn't
use TestExpectations file at all. If you want to skip it on JSC bots too, you
need to add "//@ skip" into the test js file.
Comment 2 Ryosuke Niwa 2015-04-27 03:22:50 PDT
(In reply to comment #1)
> re https://trac.webkit.org/changeset/183391 - run-javascriptcore-tests
> doesn't
> use TestExpectations file at all. If you want to skip it on JSC bots too, you
> need to add "//@ skip" into the test js file.

That's a good point. We should do that.
Comment 3 Ryosuke Niwa 2015-04-27 03:24:35 PDT
Done that in http://trac.webkit.org/changeset/183392.
Comment 4 Ryosuke Niwa 2015-05-01 18:44:23 PDT
*** Bug 144514 has been marked as a duplicate of this bug. ***
Comment 5 Ryosuke Niwa 2015-11-11 12:04:34 PST
This has been fixed.
Comment 6 Joseph Pecoraro 2016-04-07 20:11:17 PDT
Created attachment 275967 [details]
[PATCH] Proposed Fix - Unskip

Reopen to unskip.
Comment 7 Joseph Pecoraro 2016-04-08 11:14:35 PDT
Comment on attachment 275967 [details]
[PATCH] Proposed Fix - Unskip

Try again to get commit-queue to notice this.
Comment 8 Joseph Pecoraro 2016-04-08 11:17:12 PDT
Comment on attachment 275967 [details]
[PATCH] Proposed Fix - Unskip

Ugh, I'll just land manually.
Comment 9 Joseph Pecoraro 2016-04-08 11:18:39 PDT
<http://trac.webkit.org/changeset/199236>