Bug 143950

Summary: Contentextensions tests are flaky
Product: WebKit Reporter: Alexey Proskuryakov <ap>
Component: Tools / TestsAssignee: Alex Christensen <achristensen>
Status: RESOLVED FIXED    
Severity: Normal CC: achristensen, beidson, benjamin, bweinstein, sam
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch
none
Patch beidson: review+

Description Alexey Proskuryakov 2015-04-20 09:33:41 PDT
Most contentextensions tests are flaky, some of them failing a lot: 

http://webkit-test-results.appspot.com/dashboards/flakiness_dashboard.html#showAllRuns=true&tests=contentextensions

Given that even basic-filter.html fails, this seems to be something very generic, so I'm going to mark the whole directory as flaky. Alex could reproduce some flakiness locally.
Comment 1 Alex Christensen 2015-04-20 11:23:52 PDT
Created attachment 251170 [details]
Patch
Comment 2 Alex Christensen 2015-04-20 11:37:10 PDT
Created attachment 251172 [details]
Patch
Comment 3 Alex Christensen 2015-04-20 11:50:03 PDT
http://trac.webkit.org/changeset/183020