Bug 143391

Summary: Reduce the dependency on Flash in regression tests
Product: WebKit Reporter: Alexey Proskuryakov <ap>
Component: Tools / TestsAssignee: Alexey Proskuryakov <ap>
Status: RESOLVED FIXED    
Severity: Normal CC: andersca, dino, ggaren, roger_fong, thorton
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
See Also: https://bugs.webkit.org/show_bug.cgi?id=133227
Attachments:
Description Flags
patch for EWS
none
patch andersca: review+

Description Alexey Proskuryakov 2015-04-03 16:19:28 PDT
Flash is not necessarily installed on all machines, and when it is, it can be an old version that is blocked. All these differences can cause unexpected failures, depending on what you have installed.

We have a number of tests that use Flash, but somehow pass even when it is not installed. They must be not very good tests, given that they don't detect this fatal condition!

I'm going to clean up as much as I can, and to make WebKitTestRunner prevent attempts at using Flash in new tests.
Comment 1 Alexey Proskuryakov 2015-04-03 16:31:56 PDT
Created attachment 250104 [details]
patch for EWS

Chances are that I got at least a few cases wrong...

This also marks all remaining plugins/snapshotting tests as flaky, because they don't really test snapshotting at all, and just cause trouble. We would only be interested in crashes on these tests.
Comment 2 Alexey Proskuryakov 2015-04-03 16:56:23 PDT
Created attachment 250108 [details]
patch
Comment 3 Alexey Proskuryakov 2015-04-03 18:10:15 PDT
Comment on attachment 250108 [details]
patch

The patch fails to be applied (line endings?) 

But tests passed locally.
Comment 4 Anders Carlsson 2015-04-06 08:21:20 PDT
Comment on attachment 250108 [details]
patch

Can you remove the .swf files?
Comment 5 Alexey Proskuryakov 2015-04-06 09:32:30 PDT
Committed <http://trac.webkit.org/r182428>.

> Can you remove the .swf files?

Not yet - they are still used in the 8 remaining tests that are skipped on WK2, but still run on WK1. We need to associate TestNetscapePlugin with an extension, and to make it load a resource to convert these.