Bug 143273

Summary: Move ExpansionBehaviorFlags and TextDirection to their own file
Product: WebKit Reporter: Myles C. Maxfield <mmaxfield>
Component: New BugsAssignee: Myles C. Maxfield <mmaxfield>
Status: RESOLVED FIXED    
Severity: Normal CC: commit-queue, dino, hyatt, jonlee, simon.fraser, thorton
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on:    
Bug Blocks: 142608    
Attachments:
Description Flags
Patch simon.fraser: review+

Description Myles C. Maxfield 2015-03-31 12:23:57 PDT
Move ExpansionBehaviorFlags and TextDirection to their own file
Comment 1 Myles C. Maxfield 2015-03-31 12:25:36 PDT
Created attachment 249841 [details]
Patch
Comment 2 WebKit Commit Bot 2015-03-31 12:26:59 PDT
Attachment 249841 [details] did not pass style-queue:


ERROR: Source/WebCore/platform/text/TextHelpers.h:31:  enum members should use InterCaps with an initial capital letter.  [readability/enum_casing] [4]
Total errors found: 1 in 48 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 Simon Fraser (smfr) 2015-03-31 13:32:07 PDT
Comment on attachment 249841 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=249841&action=review

> Source/WebCore/platform/text/TextHelpers.h:27
> +#define TextHelpers_h

Not sure I like the name of this file. I'd expect a "helpers" file to contain a bunch of static functions that help me with text. This is more like TextFlags.h or TextRelatedEnums.h

> Source/WebCore/platform/text/TextHelpers.h:38
> +    ForbidLeadingExpansion = 0 << 1,

0 << anything is 0. Why not just say 0?
Comment 4 Myles C. Maxfield 2015-03-31 14:05:40 PDT
Comment on attachment 249841 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=249841&action=review

>> Source/WebCore/platform/text/TextHelpers.h:27
>> +#define TextHelpers_h
> 
> Not sure I like the name of this file. I'd expect a "helpers" file to contain a bunch of static functions that help me with text. This is more like TextFlags.h or TextRelatedEnums.h

Done.

>> Source/WebCore/platform/text/TextHelpers.h:38
>> +    ForbidLeadingExpansion = 0 << 1,
> 
> 0 << anything is 0. Why not just say 0?

When this enum gets more complicated, it will be more obvious what is going on.
Comment 5 Myles C. Maxfield 2015-03-31 14:35:26 PDT
Committed r182207: <http://trac.webkit.org/changeset/182207>