Bug 143098

Summary: FTL ScopedArguments GetArrayLength generates incorrect code and crashes in LLVM
Product: WebKit Reporter: Filip Pizlo <fpizlo>
Component: JavaScriptCoreAssignee: Filip Pizlo <fpizlo>
Status: RESOLVED FIXED    
Severity: Normal CC: ap, barraclough, benjamin, ggaren, mark.lam, mhahnenb, mmirman, msaboff, nrotem, oliver, saam, sam
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: All   
OS: Unspecified   
Bug Depends on:    
Bug Blocks: 141174    
Attachments:
Description Flags
the patch ossy: review+

Description Filip Pizlo 2015-03-26 08:25:15 PDT
Patch forthcoming.
Comment 1 Filip Pizlo 2015-03-26 08:26:58 PDT
Created attachment 249489 [details]
the patch
Comment 2 Csaba Osztrogon√°c 2015-03-26 08:28:55 PDT
Comment on attachment 249489 [details]
the patch

rs=me
Comment 3 Filip Pizlo 2015-03-26 08:30:58 PDT
Landed in http://trac.webkit.org/changeset/182009
Comment 4 Alexey Proskuryakov 2015-03-26 11:11:15 PDT
*** Bug 143102 has been marked as a duplicate of this bug. ***