Bug 142553

Summary: Web Inspector: Merge IssueMessage/ConsoleMessage - both attempt to modify the Console Messages parameter independently
Product: WebKit Reporter: Joseph Pecoraro <joepeck>
Component: Web InspectorAssignee: Joseph Pecoraro <joepeck>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: graouts, joepeck, jonowells, mattbaker, nvasilyev, timothy, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: 528+ (Nightly build)   
Hardware: All   
OS: All   

Description Joseph Pecoraro 2015-03-10 17:50:48 PDT
* SUMMARY
Merge IssueMessage/ConsoleMessage - both attemp to modify the Console Messages parameter independently.

This was an issue when ConsoleObserver created both objects and both modified the parameters array. Essentially an Issue is just a Console with a error/warning type.
Comment 1 Radar WebKit Bug Importer 2015-03-10 17:51:07 PDT
<rdar://problem/20115183>
Comment 2 Radar WebKit Bug Importer 2015-03-10 17:52:02 PDT
<rdar://problem/20115205>
Comment 3 Joseph Pecoraro 2016-04-22 21:10:41 PDT
I will be addressing this as part of the fix bug 150009.

*** This bug has been marked as a duplicate of bug 150009 ***