Bug 142448

Summary: DumpRenderTree and WebKitTestRunner should rename WorkQueue to something that will not be confused with WTF::WorkQueue
Product: WebKit Reporter: Brent Fulgham <bfulgham>
Component: Tools / TestsAssignee: Nobody <webkit-unassigned>
Status: NEW ---    
Severity: Normal CC: andersca, bfulgham, koivisto, sam
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: All   
OS: All   

Description Brent Fulgham 2015-03-07 20:23:47 PST
For historical reasons, DumpRenderTree and WebKitTestRunner have their own WorkQueue implementations. Now that WorkQueue lives in WTF, we should merge these disparate implementations and standardize on one implementation. This will simplify the code, as well as increasing the test coverage for this functionality.
Comment 1 Sam Weinig 2015-03-08 16:56:34 PDT
The WorkQueue classes in DRT and WKTR are not threading primitives like WTF::WorkQueue, but rather just a plain old queue of things to do (it's actually quite similar to WTF::MessageQueue). Having the same name does complicate things here, I admit.
Comment 2 Anders Carlsson 2015-03-09 15:13:55 PDT
Are they really similar enough to WTF::WorkQueue that we could just use it?
Comment 3 Brent Fulgham 2015-03-09 15:21:25 PDT
(In reply to comment #2)
> Are they really similar enough to WTF::WorkQueue that we could just use it?

Maybe not. I notice the DRT/WKTR version has the concept of being "frozen", which seems to mean "ignore any passed dispatch functions". I'm not sure we would want that "feature" to be part of the WTF::WorkQueue implementation, so maybe we should just leave things as-is.
Comment 4 Sam Weinig 2015-03-10 14:19:39 PDT
(In reply to comment #3)
> (In reply to comment #2)
> > Are they really similar enough to WTF::WorkQueue that we could just use it?
> 
> Maybe not. I notice the DRT/WKTR version has the concept of being "frozen",
> which seems to mean "ignore any passed dispatch functions". I'm not sure we
> would want that "feature" to be part of the WTF::WorkQueue implementation,
> so maybe we should just leave things as-is.

We should probably just mutate this bug into renaming the DRT/WKTR classes. I have not good ideas for names.