Bug 142406

Summary: remove more symbols from WebCore.unexp
Product: WebKit Reporter: Alex Christensen <achristensen>
Component: WebCore Misc.Assignee: Alex Christensen <achristensen>
Status: RESOLVED FIXED    
Severity: Normal CC: ddkilzer
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch ddkilzer: review+

Description Alex Christensen 2015-03-06 11:35:46 PST
Progress towards getting rid of all the exceptions and soft linking the right way.
Comment 1 Alex Christensen 2015-03-06 11:41:35 PST
Created attachment 248081 [details]
Patch
Comment 2 David Kilzer (:ddkilzer) 2015-03-06 15:47:47 PST
Comment on attachment 248081 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=248081&action=review

r=me!

> Source/WebCore/page/CaptionUserPreferencesMediaAF.cpp:68
>  #endif

I think you can remove this #endif and the #if PLATFORM(WIN) below to combine them into one block.

> Source/WebCore/page/CaptionUserPreferencesMediaAF.cpp:70
>  #if PLATFORM(WIN)

And remove this #if PLATFORM(WIN) with the #endif above.

> Source/WebCore/platform/cf/MediaAccessibilitySoftLink.cpp:32
> +#include "SoftLinking.h"
> +
> +#include <CoreText/CoreText.h>
> +#include <MediaAccessibility/MediaAccessibility.h>

Don't need a blank line here.

> Source/WebCore/platform/cf/MediaAccessibilitySoftLink.h:33
> +#include "SoftLinking.h"
> +
> +#include <CoreText/CoreText.h>
> +#include <MediaAccessibility/MediaAccessibility.h>

Don't need a blank line here.

> Source/WebCore/platform/cf/MediaAccessibilitySoftLink.h:35
> +SOFT_LINK_FRAMEWORK_HEADER(WebCore, MediaAccessibility)

Oops, I need to rename this to add "_FOR_".  Separate patch; you don't need to fix it.
Comment 3 Alex Christensen 2015-03-06 16:04:26 PST
http://trac.webkit.org/changeset/181190