Bug 142268

Summary: [GTK] Layout Test editing/pasteboard/copy-paste-attachment.html is failing
Product: WebKit Reporter: Marcos Chavarría Teijeiro (irc: chavaone) <chavarria1991>
Component: Tools / TestsAssignee: Nobody <webkit-unassigned>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: agoldmints, bugs-noreply, chavarria1991, clopez, enrica, thorton
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   

Description Marcos Chavarría Teijeiro (irc: chavaone) 2015-03-04 01:27:15 PST
The editing/pasteboard/copy-paste-attachment.html layout test is failing since it was added on r180785 (https://trac.webkit.org/changeset/r180785).

--- /home/ch01/wk-tools/layout-test-results/editing/pasteboard/copy-paste-attachment-expected.txt
+++ /home/ch01/wk-tools/layout-test-results/editing/pasteboard/copy-paste-attachment-actual.txt
@@ -7,8 +7,8 @@
 PASS attachment.file.name is 'abe.png'
 Perform Cut on the entire selection followed by Paste
 Checking the file name for the pasted attachment element
-PASS attachment.file.name is 'abe.png'
+FAIL attachment.file.name should be abe.png. Threw exception TypeError: undefined is not an object (evaluating 'attachment.file.name')
 PASS successfullyParsed is true

 TEST COMPLETE
-This is a paragraph with an attachment  and some other text.
+This is a paragraph with an attachment and some other text.
Comment 1 Arcady Goldmints-Orlov 2021-09-06 13:17:33 PDT
The root cause of this is the same as bug 141699: that the attachment element is not enabled on GLIB.
Comment 2 Arcady Goldmints-Orlov 2021-09-06 16:01:12 PDT

*** This bug has been marked as a duplicate of bug 141699 ***