Bug 141885

Summary: Bytecode generation and linking should use a stack of symbol tables rather than a stack of scopes, and scope resolution nodes should refer to the current stack of symbol tables to drive lookups rather than using dynamism for non-empty local scope stacks
Product: WebKit Reporter: Filip Pizlo <fpizlo>
Component: JavaScriptCoreAssignee: Saam Barati <sbarati>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: sbarati
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: All   
OS: All   
Bug Depends on: 141174    
Bug Blocks:    

Description Filip Pizlo 2015-02-22 18:12:07 PST
This should fix a bunch of bugs, and enable us to implement let without craziness.
Comment 1 Saam Barati 2015-06-12 13:45:33 PDT
Patch to implement block scoping in the form of 'let' will do this.

*** This bug has been marked as a duplicate of bug 142944 ***