Bug 141421

Summary: [GTK] Layout Test editing/pasteboard/simplfiying-markup-should-not-strip-content.html is failing
Product: WebKit Reporter: Marcos Chavarría Teijeiro (irc: chavaone) <chavarria1991>
Component: HTML EditingAssignee: Nobody <webkit-unassigned>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: chavarria1991, clopez, dino, galineau
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   

Description Marcos Chavarría Teijeiro (irc: chavaone) 2015-02-10 02:43:29 PST
The editing/pasteboard/simplfiying-markup-should-not-strip-content.html layout test is failing since it was changed on r179168 (http://trac.webkit.org/r179168).

The diff is the following:

--- /home/ch01/wk-tools/layout-test-results/editing/pasteboard/simplfiying-markup-should-not-strip-content-expected.txt
+++ /home/ch01/wk-tools/layout-test-results/editing/pasteboard/simplfiying-markup-should-not-strip-content-actual.txt
@@ -33,7 +33,17 @@
 |   face="Verdana"
 |   "hello "
 | <br>
-|   style="font-family: Helvetica; line-height: 18px;"
+|   style="font-family: Helvetica;"
 | <font>
 |   face="Verdana"
-|   "worldWebKit<#selection-caret>"
+|   <div>
+|     style="-webkit-line-break: after-white-space;"
+|     <div>
+|       <font>
+|         face="Verdana"
+|         "world"
+|     <div>
+|       style="-webkit-line-break: after-white-space;"
+|       <font>
+|         face="Verdana"
+|         "WebKit<#selection-caret>"

https://build.webkit.org/results/GTK%20Linux%2064-bit%20Release%20%28Tests%29/r179867%20%286096%29/editing/pasteboard/simplfiying-markup-should-not-strip-content-pretty-diff.html
Comment 1 Marcos Chavarría Teijeiro (irc: chavaone) 2015-02-10 04:41:41 PST

*** This bug has been marked as a duplicate of bug 141423 ***