Bug 141081

Summary: OSObjectPtr does not work with dispatch_data_t on Maverics
Product: WebKit Reporter: Antti Koivisto <koivisto>
Component: Web Template FrameworkAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: commit-queue, sam
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on: 141117    
Bug Blocks: 141022    
Attachments:
Description Flags
patch
psolanki: review+
use DispatchPtr instead zalan: review+

Description Antti Koivisto 2015-01-30 05:48:04 PST
2015-01-30 15:43:57.680 com.apple.WebKit.Networking.Development[57008:1c07] -[OS_dispatch_data _xref_dispose]: unrecognized selector sent to instance 0x7f899fa021d0
Comment 1 Antti Koivisto 2015-01-30 06:04:56 PST
Created attachment 245717 [details]
patch
Comment 2 Antti Koivisto 2015-01-30 12:46:30 PST
https://trac.webkit.org/r179408
Comment 3 WebKit Commit Bot 2015-01-31 09:39:36 PST
Re-opened since this is blocked by bug 141117
Comment 4 Antti Koivisto 2015-01-31 09:44:51 PST
Though this worked locally it doesn't seem to work on bots. This might be because the definition of dispatch_data_t varies based on context (objc or not etc) and so the template matching is not consistent.
Comment 5 Antti Koivisto 2015-01-31 11:50:58 PST
Created attachment 245790 [details]
use DispatchPtr instead

Enabling the cache so bots see the change. That will land separately.
Comment 6 Antti Koivisto 2015-01-31 12:43:55 PST
https://trac.webkit.org/r179446