Bug 141043

Summary: Frequent kernel panics when running WebKit regression tests
Product: WebKit Reporter: Alexey Proskuryakov <ap>
Component: WebKit2Assignee: Alexey Proskuryakov <ap>
Status: RESOLVED FIXED    
Severity: Normal CC: andersca, commit-queue, mrowe, sam
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
See Also: https://bugs.webkit.org/show_bug.cgi?id=141309
https://bugs.webkit.org/show_bug.cgi?id=148683
Attachments:
Description Flags
proposed fix
none
with more project fixes none

Description Alexey Proskuryakov 2015-01-29 12:39:52 PST
Due to <rdar://problem/11806093>, re-exec of PluginService can sometimes (rarely) cause a kernel panic when switching from 64 bit to 32 bit. But this is not so rare on the bots.
Comment 1 Alexey Proskuryakov 2015-01-29 12:48:54 PST
Created attachment 245639 [details]
proposed fix
Comment 2 Alexey Proskuryakov 2015-01-29 12:57:04 PST
Created attachment 245641 [details]
with more project fixes
Comment 3 Sam Weinig 2015-01-29 13:19:23 PST
Comment on attachment 245641 [details]
with more project fixes

I don't see you removing passing the architecture to service.  That can (and should) probably be ripped out.
Comment 4 Alexey Proskuryakov 2015-01-29 13:29:48 PST
Comment on attachment 245641 [details]
with more project fixes

Good point. Let's do that once we have a confirmation that this patch helped.
Comment 5 WebKit Commit Bot 2015-01-29 14:14:30 PST
Comment on attachment 245641 [details]
with more project fixes

Clearing flags on attachment: 245641

Committed r179367: <http://trac.webkit.org/changeset/179367>
Comment 6 WebKit Commit Bot 2015-01-29 14:14:34 PST
All reviewed patches have been landed.  Closing bug.