Bug 140798

Summary: [Win] Accessibility implementation unable to recurse through document (sometimes) to find named elements
Product: WebKit Reporter: Brent Fulgham <bfulgham>
Component: AccessibilityAssignee: Brent Fulgham <bfulgham>
Status: RESOLVED FIXED    
Severity: Normal CC: bfulgham, commit-queue, jdiggs, pvollan, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: 528+ (Nightly build)   
Hardware: PC   
OS: All   
See Also: https://bugs.webkit.org/show_bug.cgi?id=140830
https://bugs.webkit.org/show_bug.cgi?id=146243
Attachments:
Description Flags
Patch
none
Archive of layout-test-results from ews112 for mac-yosemite none

Description Brent Fulgham 2015-01-22 16:09:51 PST
The layout test 'accessibility/aria-controls-with-tabs.html' is failing as follows:

--- /cygdrive/c/Projects/WebKit/OpenSource/WebKitBuild/Release/bin32/layout-test-results/accessibility/aria-controls-with-tabs-expected.txt
+++ /cygdrive/c/Projects/WebKit/OpenSource/WebKitBuild/Release/bin32/layout-test-results/accessibility/aria-controls-with-tabs-actual.txt
@@ -1,3 +1,4 @@
+CONSOLE MESSAGE: line 34: TypeError: undefined is not an object (evaluating 'tabList.childAtIndex')
 Crust
 Veges
 Test
@@ -11,11 +12,7 @@
 On success, you will see a series of "PASS" messages, followed by "TEST COMPLETE".
 
 
-PASS tab2.isSelected is true
-PASS tab1.isSelected is false
-PASS tab2.isSelected is false
-PASS tab1.isSelected is true
-PASS successfullyParsed is true
+FAIL successfullyParsed should be true (of type boolean). Was undefined (of type undefined).
 
 TEST COMPLETE
Comment 1 Radar WebKit Bug Importer 2015-01-22 16:10:27 PST
<rdar://problem/19571554>
Comment 2 Brent Fulgham 2015-01-23 09:22:07 PST
*** Bug 140797 has been marked as a duplicate of this bug. ***
Comment 3 Brent Fulgham 2015-01-23 09:22:57 PST
A series of layout test failures are being caused by the inability of the Windows accessibility code to drill down into the document to find elements. I'm not sure what triggers this failure, as some tests seem to work fine.
Comment 4 Per Arne Vollan 2016-06-16 06:37:31 PDT
Created attachment 281452 [details]
Patch
Comment 5 Build Bot 2016-06-16 07:33:54 PDT
Comment on attachment 281452 [details]
Patch

Attachment 281452 [details] did not pass mac-debug-ews (mac):
Output: http://webkit-queues.webkit.org/results/1512867

New failing tests:
css3/filters/backdrop/backdrop-filter-with-reflection.html
Comment 6 Build Bot 2016-06-16 07:33:57 PDT
Created attachment 281455 [details]
Archive of layout-test-results from ews112 for mac-yosemite

The attached test failures were seen while running run-webkit-tests on the mac-debug-ews.
Bot: ews112  Port: mac-yosemite  Platform: Mac OS X 10.10.5
Comment 7 Brent Fulgham 2016-06-16 16:40:23 PDT
Comment on attachment 281452 [details]
Patch

r=me. The mac-debug failure is unrelated to this Windows-specific patch.
Comment 8 WebKit Commit Bot 2016-06-16 17:00:41 PDT
Comment on attachment 281452 [details]
Patch

Clearing flags on attachment: 281452

Committed r202149: <http://trac.webkit.org/changeset/202149>
Comment 9 WebKit Commit Bot 2016-06-16 17:00:45 PDT
All reviewed patches have been landed.  Closing bug.
Comment 10 Per Arne Vollan 2016-06-23 03:10:54 PDT
Updated test expectations in https://trac.webkit.org/changeset/202375.