Bug 140530

Summary: std::all_of requires complete C++ iterators in GCC 4.8
Product: WebKit Reporter: Yusuke Suzuki <ysuzuki>
Component: New BugsAssignee: Yusuke Suzuki <ysuzuki>
Status: RESOLVED FIXED    
Severity: Normal CC: andersca, benjamin, cmarcelo, commit-queue, darin, kling, ossy
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on:    
Bug Blocks: 140469    
Attachments:
Description Flags
Patch
none
Patch none

Description Yusuke Suzuki 2015-01-15 17:49:53 PST
std::all_of requires complete C++ iterators in GCC 4.8
Comment 1 Yusuke Suzuki 2015-01-15 17:53:15 PST
Created attachment 244739 [details]
Patch
Comment 2 Yusuke Suzuki 2015-01-15 18:31:57 PST
Oops, I'll fix a little
Comment 3 Yusuke Suzuki 2015-01-15 18:49:35 PST
Created attachment 244743 [details]
Patch
Comment 4 Yusuke Suzuki 2015-01-15 18:50:12 PST
Updated the patch, annotating inheritance as `public`.
Comment 5 Csaba Osztrogon√°c 2015-01-15 23:28:05 PST
Is this bug to fix the GTK debug build break caused by 178452?
( https://bugs.webkit.org/show_bug.cgi?id=140469#c5 )
Comment 6 Yusuke Suzuki 2015-01-16 00:25:00 PST
(In reply to comment #5)
> Is this bug to fix the GTK debug build break caused by 178452?
> ( https://bugs.webkit.org/show_bug.cgi?id=140469#c5 )

Yeah, that's correct.
Comment 7 Darin Adler 2015-01-16 09:34:14 PST
Comment on attachment 244743 [details]
Patch

This looks fine to me. Are these really the only classes that need this in WebKit? It also seems that we should remove some of our own typedefs and use the ones from std::iterator as further cleanup after this.
Comment 8 WebKit Commit Bot 2015-01-16 10:15:38 PST
Comment on attachment 244743 [details]
Patch

Clearing flags on attachment: 244743

Committed r178581: <http://trac.webkit.org/changeset/178581>
Comment 9 WebKit Commit Bot 2015-01-16 10:15:44 PST
All reviewed patches have been landed.  Closing bug.